summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-07 13:47:39 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-20 10:30:06 +0100
commit41c5f1b7795d95179d1b501fc93b27abd6c19d27 (patch)
tree688c479d01b3ae9f5c6de24bc2ebcbee2068afc8 /testsuites/libtests/configure.ac
parentAdd RTEMS port of Linux I2C user-space API (diff)
downloadrtems-41c5f1b7795d95179d1b501fc93b27abd6c19d27.tar.bz2
Add I2C driver framework
This I2C driver framework has some major differences compared to libi2c. * It is compatible to the Linux I2C user-space API. * It uses generic IMFS nodes and thus reduces the levels of indirection. * The drivers don't have to mess around with minor numbers to get their state information. * No arbitrary bus controller model is assumed. The main task of an I2C bus controller driver is to process I2C messages. How this is done is private to the driver. * Scatter/gather operations are supported (I2C_M_NOSTART).
Diffstat (limited to 'testsuites/libtests/configure.ac')
-rw-r--r--testsuites/libtests/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/testsuites/libtests/configure.ac b/testsuites/libtests/configure.ac
index 7d4871d447..fccdc1d12c 100644
--- a/testsuites/libtests/configure.ac
+++ b/testsuites/libtests/configure.ac
@@ -66,6 +66,7 @@ AS_IF([test x"$HAVE_LIBDL" = x"yes"],[
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
+i2c01/Makefile
newlib01/Makefile
block17/Makefile
exit02/Makefile