summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-03-14 08:20:54 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-03-27 07:21:31 +0100
commitcbfc3415607a6943823e8fc47c38408dcc7dbd90 (patch)
treebe339544970fd3cae506c38521d98aa173ebedf7 /testsuites/libtests/Makefile.am
parentAdd RTEMS Test Framework (diff)
downloadrtems-cbfc3415607a6943823e8fc47c38408dcc7dbd90.tar.bz2
ttest01: New test
This is an example test using the RTEMS Test Framework. It tests also the framework itself. Add T_FILE_NAME command line define to get rid of the full file path. This is important to reduce the read-only data of test files and make them build system independent. Update #3199.
Diffstat (limited to 'testsuites/libtests/Makefile.am')
-rw-r--r--testsuites/libtests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/testsuites/libtests/Makefile.am b/testsuites/libtests/Makefile.am
index fe6f7d8ee8..1b80283123 100644
--- a/testsuites/libtests/Makefile.am
+++ b/testsuites/libtests/Makefile.am
@@ -1500,6 +1500,16 @@ top_SOURCES = top/init.c top/task1.c top/task2.c top/task3.c \
top_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_top) $(support_includes)
endif
+if TEST_ttest01
+lib_tests += ttest01
+lib_screens += ttest01/ttest01.scn
+lib_docs += ttest01/ttest01.doc
+ttest01_SOURCES = ttest01/init.c
+ttest01_SOURCES += ttest01/test-example.c
+ttest01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_ttest01) \
+ $(support_includes)
+endif
+
if TEST_tztest
lib_tests += tztest
lib_screens += tztest/tztest.scn