summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-08-30 15:01:38 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-10-01 09:55:07 +0200
commita314544a278f1533ae001f742d7fe24fcee253e6 (patch)
tree64b5cec3ddc5111df8f229fdbd57376d66195043 /testsuites/libtests/Makefile.am
parentMAINTAINERS: Remove Martin Galvan (diff)
downloadrtems-a314544a278f1533ae001f742d7fe24fcee253e6.tar.bz2
record: Add wrappers for malloc() functions
Introduce new library librtemsrecordwrap.a which contains wrappers for operating system functions which produce entry/exit events. The wrappers can be selected during link time via the GNU ld --wrap option. Update #3665.
Diffstat (limited to 'testsuites/libtests/Makefile.am')
-rw-r--r--testsuites/libtests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/testsuites/libtests/Makefile.am b/testsuites/libtests/Makefile.am
index 1b80283123..406961ca73 100644
--- a/testsuites/libtests/Makefile.am
+++ b/testsuites/libtests/Makefile.am
@@ -1160,6 +1160,14 @@ lib_docs += record02/record02.doc
record02_SOURCES = record02/init.c
record02_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_record02) \
$(support_includes)
+record02_LDADD = $(LDADD) $(RTEMS_ROOT)cpukit/librtemsrecordwrap.a $(LDADD)
+record02_LDFLAGS = $(AM_LDFLAGS)
+record02_LDFLAGS += -Wl,--wrap=aligned_alloc
+record02_LDFLAGS += -Wl,--wrap=calloc
+record02_LDFLAGS += -Wl,--wrap=malloc
+record02_LDFLAGS += -Wl,--wrap=free
+record02_LDFLAGS += -Wl,--wrap=posix_memalign
+record02_LDFLAGS += -Wl,--wrap=realloc
endif
if TEST_rtmonuse