summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2019-01-22 08:48:19 +1100
committerChris Johns <chrisj@rtems.org>2019-02-09 10:06:34 +1100
commit194eb403c39f5ad346e63dc3352e29570857fd93 (patch)
tree3ef4976810a6e4545a0d4c68138c270ed3abd22c /testsuites/libtests/Makefile.am
parentlibdl: Add support for trampolines (diff)
downloadrtems-194eb403c39f5ad346e63dc3352e29570857fd93.tar.bz2
libdl: Add support for large memory programs
- Add trampolines to support relocs that are out of range on support architectures. - Support not loading separate text/data sections in an object file if the symbol provided in the section is a duplicate. A base image may have pulled in part of an object and another part needs to be dynamically loaded. - Refactor the unresolved handling to scale to hundreds of unresolved symbols when loading large number of files. Updates #3685
Diffstat (limited to 'testsuites/libtests/Makefile.am')
-rw-r--r--testsuites/libtests/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/testsuites/libtests/Makefile.am b/testsuites/libtests/Makefile.am
index 22cf613dd3..166f45e21b 100644
--- a/testsuites/libtests/Makefile.am
+++ b/testsuites/libtests/Makefile.am
@@ -576,16 +576,19 @@ dl08-o5.o: dl08/dl-o5.c Makefile
$(AM_V_CC)$(COMPILE) -c -o $@ $<
dl08-o6-123456789-123456789.o: dl08/dl-o6-123456789-123456789.c Makefile
$(AM_V_CC)$(COMPILE) -c -o $@ $<
-# echo "#" > etc/rtl-libs.conf
-# echo " # blah blah" >> etc/rtl-libs.conf
-etc/rtl-libs.conf:
+etc/libdl.conf:
mkdir etc; \
- echo "/libdl08*.a" >> etc/rtl-libs.conf
+ echo "#" > etc/libdl.conf
+ echo " # blah blah" >> etc/libdl.conf
+ echo "/libdl08*.a" >> etc/libdl.conf
+ echo "" >> etc/libdl.conf
+ echo "x" >> etc/libdl.conf
+ echo "" >> etc/libdl.conf
noinst_LIBRARIES = libdl08_1.a libdl08_2.a
libdl08_1_a_SOURCES = dl08-o2.c dl08-o4.c
libdl08_2_a_SOURCES = dl08-o3.c dl08-o5.c \
dl08-o6-123456789-123456789.c
-dl08.tar: etc/rtl-libs.conf dl08-o1.o libdl08_1.a libdl08_2.a
+dl08.tar: etc/libdl.conf dl08-o1.o libdl08_1.a libdl08_2.a
@rm -f $@
$(AM_V_GEN)$(PAX) -w -f $@ $+
dl08-tar.c: dl08.tar
@@ -601,7 +604,7 @@ dl08$(EXEEXT): $(dl08_OBJECTS) $(dl08_DEPENDENCIES) dl08-sym.o
$(AM_V_CCLD)$(LINK.c) $(CPU_CFLAGS) $(AM_CFLAGS) $(AM_LDFLAGS) -o $@ $+
CLEANFILES += dl08.pre dl08-sym.o libdl08_1.a libdl08_2.a dl08-o1.o dl08-o2.o \
dl08-o3.o dl08-o4.o dl08-o5.o dl08-o6-123456789-123456789.o \
- dl08.tar dl08-tar.h etc/rtl-libs.conf
+ dl08.tar dl08-tar.h etc/libdl.conf
endif
endif