summaryrefslogtreecommitdiffstats
path: root/testsuites/fstests/Makefile.am
diff options
context:
space:
mode:
authorAndre Marques <andre.lousa.marques@gmail.com>2014-02-22 21:57:34 +0000
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-17 10:21:56 +0100
commit27d240e050697cf3d5b1632fafd2312c5bc26e52 (patch)
tree0a74f668fae3713aeb719333434ce26a1d60672c /testsuites/fstests/Makefile.am
parentscore: Use only next field for chain on/off (diff)
downloadrtems-27d240e050697cf3d5b1632fafd2312c5bc26e52.tar.bz2
New fstest to check rename POSIX conformance
This patch is a newer version of the test presented on http://www.rtems.org/pipermail/rtems-devel/2014-February/005318.html Unchecked error cases: - EIO (physical error) - ENOSPC (no space left in the new filepath) - EROFS (already covered on testsuites/fstests/fsrofs01) Untested functionality: - File system lock during rename() operation - If after rename() the link count of a file becomes 0 it should be removed and the space ocupied by the file shall be freed and no longer accessible (the function statvfs() gives "not implemented" on the imfs file system, so this is postponed for now)
Diffstat (limited to 'testsuites/fstests/Makefile.am')
-rw-r--r--testsuites/fstests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/testsuites/fstests/Makefile.am b/testsuites/fstests/Makefile.am
index ed87f1b12f..539a2203f8 100644
--- a/testsuites/fstests/Makefile.am
+++ b/testsuites/fstests/Makefile.am
@@ -31,6 +31,7 @@ SUBDIRS += mimfs_fspermission
SUBDIRS += mimfs_fsrdwr
SUBDIRS += mimfs_fssymlink
SUBDIRS += mimfs_fstime
+SUBDIRS += mimfs_fsrename
SUBDIRS += mrfs_fserror
SUBDIRS += mrfs_fslink
SUBDIRS += mrfs_fspatheval