summaryrefslogtreecommitdiffstats
path: root/testsuites/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-06-28 21:09:13 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-06-28 21:09:13 +0000
commit152a28418871061a20dabfc4c73990b96cf18e93 (patch)
tree1f5a2c1add0875a0631adc68fe19d5e83255e15e /testsuites/configure.ac
parent2011-06-28 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-152a28418871061a20dabfc4c73990b96cf18e93.tar.bz2
2011-06-28 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, support/include/test_support.h: * support/src/locked_print.c: New file.
Diffstat (limited to 'testsuites/configure.ac')
-rw-r--r--testsuites/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/configure.ac b/testsuites/configure.ac
index 001aab1691..2e0d3e1fa9 100644
--- a/testsuites/configure.ac
+++ b/testsuites/configure.ac
@@ -25,6 +25,7 @@ RTEMS_PROG_CC
RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
RTEMS_CHECK_CPUOPTS([RTEMS_MULTIPROCESSING])
RTEMS_CHECK_CPUOPTS([RTEMS_NETWORKING])
+RTEMS_CHECK_CPUOPTS([RTEMS_SMP])
case $enable_tests in
yes | samples )
@@ -38,6 +39,9 @@ if test "$enable_tests" = "yes"; then
if test "$rtems_cv_RTEMS_MULTIPROCESSING" = "yes"; then
AC_CONFIG_SUBDIRS(mptests)
fi
+ if test "$rtems_cv_RTEMS_SMP" = "yes"; then
+ AC_CONFIG_SUBDIRS(smptests)
+ fi
# Now do performance tests
AC_CONFIG_SUBDIRS(tmtests psxtmtests)
fi