summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/sptests/sp19/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-12 10:00:10 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-12 10:53:16 +0200
commitee537ea3dd964d4de3565a36b4857af31fb5a3f4 (patch)
treead8b328a58469ca0632e3e61cd94f37c9d97cc25 /testsuites/ada/sptests/sp19/Makefile.am
parentada-tests: Use _SUBDIRS instead of SUBDIRS (diff)
downloadrtems-ee537ea3dd964d4de3565a36b4857af31fb5a3f4.tar.bz2
ada-tests: Move to testsuites/ada
This solves a build dependency issue, e.g. building tests before librtemsbsp.a exists. Close #3079.
Diffstat (limited to 'testsuites/ada/sptests/sp19/Makefile.am')
-rw-r--r--testsuites/ada/sptests/sp19/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/testsuites/ada/sptests/sp19/Makefile.am b/testsuites/ada/sptests/sp19/Makefile.am
new file mode 100644
index 0000000000..27e7d7ca28
--- /dev/null
+++ b/testsuites/ada/sptests/sp19/Makefile.am
@@ -0,0 +1,20 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+AM_ADAFLAGS += -I.
+
+noinst_PROGRAMS = ada_sp19
+ada_sp19_SOURCES = sp19.adb sptest.adb config.h sptest.ads
+ada_sp19_SOURCES += ../../support/init.c
+
+CLEANFILES += sptest.adb
+
+ada_sp19$(EXEEXT): sp19.adb sptest.adb sptest.ads init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+scndir = $(rtems_ada_testsdir)
+dist_scn_DATA = ada_sp19.scn
+
+include $(top_srcdir)/../automake/local.am