summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/samples/hello/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-27 11:41:06 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-27 11:50:09 +0100
commit1fca16659754d1e7c0ac12a81bd24003dbc80c56 (patch)
tree789e045cd6ab7a3977d34e5a517025b563f0b02f /testsuites/ada/samples/hello/Makefile.am
parentuntar: Properly make parent path (diff)
downloadrtems-1fca16659754d1e7c0ac12a81bd24003dbc80c56.tar.bz2
testsuites/ada: Introduce init.c files
Provide an init.c for each Ada test instead of the #include <config.h> magic which works only due to hand crafted include paths. Update #3818.
Diffstat (limited to 'testsuites/ada/samples/hello/Makefile.am')
-rw-r--r--testsuites/ada/samples/hello/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/testsuites/ada/samples/hello/Makefile.am b/testsuites/ada/samples/hello/Makefile.am
index 9efde9006e..3e3fefcf44 100644
--- a/testsuites/ada/samples/hello/Makefile.am
+++ b/testsuites/ada/samples/hello/Makefile.am
@@ -6,7 +6,7 @@ include $(top_srcdir)/ada.am
ada_hello$(EXEEXT): hello.adb init.$(OBJEXT)
$(GNATCOMPILE) -margs -a $< -o $@
-init.$(OBJEXT): ../../support/init.c
+init.$(OBJEXT): init.c
$(COMPILE.c) $(AM_CPPFLAGS) -I$(srcdir) -c $<
noinst_PROGRAMS = ada_hello