summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/mptests/mp01/node1/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-12 10:00:10 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-12 10:53:16 +0200
commitee537ea3dd964d4de3565a36b4857af31fb5a3f4 (patch)
treead8b328a58469ca0632e3e61cd94f37c9d97cc25 /testsuites/ada/mptests/mp01/node1/Makefile.am
parentada-tests: Use _SUBDIRS instead of SUBDIRS (diff)
downloadrtems-ee537ea3dd964d4de3565a36b4857af31fb5a3f4.tar.bz2
ada-tests: Move to testsuites/ada
This solves a build dependency issue, e.g. building tests before librtemsbsp.a exists. Close #3079.
Diffstat (limited to 'testsuites/ada/mptests/mp01/node1/Makefile.am')
-rw-r--r--testsuites/ada/mptests/mp01/node1/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/ada/mptests/mp01/node1/Makefile.am b/testsuites/ada/mptests/mp01/node1/Makefile.am
new file mode 100644
index 0000000000..154504ae33
--- /dev/null
+++ b/testsuites/ada/mptests/mp01/node1/Makefile.am
@@ -0,0 +1,19 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+AM_ADAFLAGS += -I$(srcdir)/..
+
+noinst_PROGRAMS = mp01_ada_mp01_node1
+mp01_ada_mp01_node1_SOURCES = mp01_node1.adb ../mptest.adb config.h
+mp01_ada_mp01_node1_SOURCES += ../mptest.ads
+mp01_ada_mp01_node1_SOURCES += ../../../support/init.c
+
+mp01_ada_mp01_node1$(EXEEXT): mp01_node1.adb ../mptest.adb init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+scndir = $(rtems_ada_testsdir)
+dist_scn_DATA = ada_mp01-node1.scn
+
+include $(top_srcdir)/../automake/local.am