summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/mptests/mp01/node1/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-27 11:41:06 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-27 11:50:09 +0100
commit1fca16659754d1e7c0ac12a81bd24003dbc80c56 (patch)
tree789e045cd6ab7a3977d34e5a517025b563f0b02f /testsuites/ada/mptests/mp01/node1/Makefile.am
parentuntar: Properly make parent path (diff)
downloadrtems-1fca16659754d1e7c0ac12a81bd24003dbc80c56.tar.bz2
testsuites/ada: Introduce init.c files
Provide an init.c for each Ada test instead of the #include <config.h> magic which works only due to hand crafted include paths. Update #3818.
Diffstat (limited to 'testsuites/ada/mptests/mp01/node1/Makefile.am')
-rw-r--r--testsuites/ada/mptests/mp01/node1/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/testsuites/ada/mptests/mp01/node1/Makefile.am b/testsuites/ada/mptests/mp01/node1/Makefile.am
index 7d78a6f9a2..45b7f4b303 100644
--- a/testsuites/ada/mptests/mp01/node1/Makefile.am
+++ b/testsuites/ada/mptests/mp01/node1/Makefile.am
@@ -8,7 +8,7 @@ AM_ADAFLAGS += -I$(srcdir)/..
noinst_PROGRAMS = mp01_ada_mp01_node1
mp01_ada_mp01_node1_SOURCES = mp01_node1.adb ../mptest.adb config.h
mp01_ada_mp01_node1_SOURCES += ../mptest.ads
-mp01_ada_mp01_node1_SOURCES += ../../../support/init.c
+mp01_ada_mp01_node1_SOURCES += init.c
mp01_ada_mp01_node1$(EXEEXT): mp01_node1.adb ../mptest.adb init.$(OBJEXT)
$(GNATCOMPILE) -margs -a $< -o $@