summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-12 10:00:10 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-12 10:53:16 +0200
commitee537ea3dd964d4de3565a36b4857af31fb5a3f4 (patch)
treead8b328a58469ca0632e3e61cd94f37c9d97cc25 /testsuites/ada/Makefile.am
parentada-tests: Use _SUBDIRS instead of SUBDIRS (diff)
downloadrtems-ee537ea3dd964d4de3565a36b4857af31fb5a3f4.tar.bz2
ada-tests: Move to testsuites/ada
This solves a build dependency issue, e.g. building tests before librtemsbsp.a exists. Close #3079.
Diffstat (limited to 'testsuites/ada/Makefile.am')
-rw-r--r--testsuites/ada/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/testsuites/ada/Makefile.am b/testsuites/ada/Makefile.am
new file mode 100644
index 0000000000..4fdae0c211
--- /dev/null
+++ b/testsuites/ada/Makefile.am
@@ -0,0 +1,13 @@
+ACLOCAL_AMFLAGS = -I aclocal -I ../aclocal
+
+_SUBDIRS = support samples sptests tmtests
+if HAS_MP
+_SUBDIRS += mptests
+endif
+
+DIST_SUBDIRS = support samples sptests tmtests mptests
+
+EXTRA_DIST = ada.am
+
+include $(top_srcdir)/../automake/subdirs.am
+include $(top_srcdir)/../automake/local.am