summaryrefslogtreecommitdiffstats
path: root/scripts/rtemsdoc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-10 16:41:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-10 16:41:08 +0000
commitbeabcaf9363fc7cf9d2ed98cb994e5f8ddb5b25a (patch)
tree35fb5a3e8865da7440be50569ee080dc145b3c03 /scripts/rtemsdoc/Makefile.am
parent2004-02-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-beabcaf9363fc7cf9d2ed98cb994e5f8ddb5b25a.tar.bz2
2004-02-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove rtemsdoc/mkspec. Add RTEMS_RPM_RELEASE. * rtemsdoc/.cvsignore: Reformat. * Makefile.am: Reformat. Add RTEMS_RPM_RELEASE support to rtems-source.add, Use rtems_source_spec_DEPS instead of rtems_source_spec_DEPENDENCIES (Conflicts with automake internals). * rtems/rtems-source.add: Add RTEMS_RPM_RELEASE. * rtemsdoc/mkspec.in: Remove. * rtemsdoc/Makefile.am: Reworked. * rtemsdoc/header.add: Update Copyright notice. * rtemsdoc/rtemsdoc.add: Add RTEMS_RPM_RELEASE. Add %{rpmgroup}. Remove bzip-ing *.ps. * rtemsdoc/supplement.add.in: Add %{rpmgroup}. * rtemsdoc/templ.add.in: Add %{rpmgroup}.
Diffstat (limited to 'scripts/rtemsdoc/Makefile.am')
-rw-r--r--scripts/rtemsdoc/Makefile.am27
1 files changed, 7 insertions, 20 deletions
diff --git a/scripts/rtemsdoc/Makefile.am b/scripts/rtemsdoc/Makefile.am
index aed74f5b2d..488b93de54 100644
--- a/scripts/rtemsdoc/Makefile.am
+++ b/scripts/rtemsdoc/Makefile.am
@@ -6,14 +6,10 @@ include ${top_srcdir}/common/common.am
CLEANFILES =
-MKSPEC = $(SHELL) ./mkspec
-
-MKSPEC_DEPS = mkspec rtemsdoc.spec.in $(top_builddir)/setup.cache
-
SUPPLEMENTS = arm c4x i386 i960 m68k mips powerpc sh sparc
DOCS = ada_user posix1003_1 bsp_howto
-DOCS += c_user
+DOCS += c_user posix_users
DOCS += develenv
DOCS += FAQ filesystem itron
DOCS += networking porting new_chapters
@@ -39,22 +35,13 @@ SUFFIXES = -supplement.add -docs.add
t=`echo $@ | sed -e 's,-docs.add,,'`; \
sed -e s/@target\@/$$t/g < $< >$@
-rtemsdoc.spec.in: $(SUBPACKAGES)
- cat $^ > $@
-CLEANFILES += rtemsdoc.spec.in
-
-rtemsdoc.spec: $(MKSPEC_DEPS) $(SUBPACKAGES)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache > $@
+rtemsdoc.spec: $(SUBPACKAGES) Makefile
+ cat $(SUBPACKAGES) | sed \
+ -e 's,[@]rtems_version[@],$(RTEMS_VERSION),g' \
+ -e 's,[@]rtems_rpm_release[@],$(RTEMS_RPM_RELEASE),g' \
+ > $@
CLEANFILES += rtemsdoc.spec
-RPM_SPECS_DATA = rtemsdoc.spec
-
-TEMPLATES = rtemsdoc.spec.in
-
-noinst_DATA = $(TEMPLATES)
-
-EXTRA_DIST = $(TEMPLATES)
-
-CLEANFILES += $(RPM_SPECS_DATA)
+noinst_DATA = rtemsdoc.spec
include $(top_srcdir)/../automake/local.am