summaryrefslogtreecommitdiffstats
path: root/scripts/rtemsdoc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-01-31 06:22:09 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-01-31 06:22:09 +0000
commit59292fe9afa08d5b150e238ed45b3a5e2f88dbcc (patch)
treebf2e4120f4db42090a3b919f2f41013ea5f66bc2 /scripts/rtemsdoc/Makefile.am
parent2003-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-59292fe9afa08d5b150e238ed45b3a5e2f88dbcc.tar.bz2
2003-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* rtemsdoc/Makefile.am: Use $(top_builddir)/common/common.add, $(top_builddir)/common/clean.add, header.add. Generate rtemsdoc.spec.in. * rtemsdoc/mkspec.in: Remove exe_ext. * rtemsdoc/rtemsdoc.spec.in: Remove. * gccnewlib/Makefile.am: Use $(top_builddir)/common/common.add, $(top_builddir)/common/clean.add, header.add. * gccnewlib/base-gcc.m4: Replace @exe_ext@ with %{_exeext}. * gccnewlib/base-gcj.add: Replace @exe_ext@ with %{_exeext}. * gccnewlib/gccnewlib.add: Replace @exe_ext@ with %{_exeext}. Remove header, broken cdn-X configuration, %clean. * gccnewlib/target-g77.add: Replace @exe_ext@ with %{_exeext}. * gccnewlib/target-gcc.add: Replace @exe_ext@ with %{_exeext}. * gccnewlib/target-gcj.add: Replace @exe_ext@ with %{_exeext}. * gccnewlib/target-objc.add: Replace @exe_ext@ with %{_exeext}.
Diffstat (limited to 'scripts/rtemsdoc/Makefile.am')
-rw-r--r--scripts/rtemsdoc/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/scripts/rtemsdoc/Makefile.am b/scripts/rtemsdoc/Makefile.am
index 939fc85686..fd205e54e4 100644
--- a/scripts/rtemsdoc/Makefile.am
+++ b/scripts/rtemsdoc/Makefile.am
@@ -30,7 +30,11 @@ DOCS += networking porting new_chapters
DOCS += relnotes rgdb_specs rtems_gdb
DOCS += started started_ada
-SUBPACKAGES = $(DOCS:%=%-docs.add)
+SUBPACKAGES = header.add
+SUBPACKAGES += ../common/common.add
+SUBPACKAGES += rtemsdoc.add
+SUBPACKAGES += ../common/clean.add
+SUBPACKAGES += $(DOCS:%=%-docs.add)
CLEANFILES += $(DOCS:%=%-docs.add)
SUBPACKAGES += $(SUPPLEMENTS:%=%-supplement.add)
CLEANFILES += $(SUPPLEMENTS:%=%-supplement.add)
@@ -45,9 +49,13 @@ SUFFIXES = -supplement.add -docs.add
t=`echo $@ | sed -e 's,-docs.add,,'`; \
sed -e s/@target\@/$$t/g < $< >$@
+rtemsdoc.spec.in: $(SUBPACKAGES)
+ cat $^ > $@
+CLEANFILES += rtemsdoc.spec.in
+
rtemsdoc.spec: $(MKSPEC_DEPS) $(SUBPACKAGES)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . > $@
- cat $(SUBPACKAGES) >> $@
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache > $@
+CLEANFILES += rtemsdoc.spec
RPM_SPECS_DATA = rtemsdoc.spec