summaryrefslogtreecommitdiffstats
path: root/scripts/rtems/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-04-13 17:02:59 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-04-13 17:02:59 +0000
commit0b1af095ef208e21e8115e5f456a4d176d9efba7 (patch)
tree06b2fcd685b47071d9b6c50a15be31d701d914c9 /scripts/rtems/Makefile.am
parentAdd mkspec. (diff)
downloadrtems-0b1af095ef208e21e8115e5f456a4d176d9efba7.tar.bz2
2005-04-13 Ralf Corsepius <ralf.corsepius@rtems.org>
* rtems/Makefile.am: Reworked.
Diffstat (limited to 'scripts/rtems/Makefile.am')
-rw-r--r--scripts/rtems/Makefile.am30
1 files changed, 17 insertions, 13 deletions
diff --git a/scripts/rtems/Makefile.am b/scripts/rtems/Makefile.am
index 6ac7784b4d..07955bb726 100644
--- a/scripts/rtems/Makefile.am
+++ b/scripts/rtems/Makefile.am
@@ -4,9 +4,22 @@
include $(top_srcdir)/common/common.am
-MKBSPSPEC = $(SHELL) $(top_builddir)/mkbspspec
+SUBPACKAGES = header.add
+SUBPACKAGES += $(top_builddir)/common/common.add
+SUBPACKAGES += rtems.add
+SUBPACKAGES += $(top_builddir)/common/clean.add
+SUBPACKAGES += target-rtems.add
-MKBSPSPEC_DEPS = $(top_builddir)/mkbspspec rtems.spec.in \
+noinst_DATA = rtems.spec.in
+
+rtems.spec.in: $(SUBPACKAGES)
+ cat $^ > $@
+CLEANFILES = rtems.spec.in
+RPM_SPECS_DATA =
+
+MKBSPSPEC = $(SHELL) ./mkspec
+
+MKBSPSPEC_DEPS = $(top_builddir)/mkspec rtems.spec.in \
$(top_builddir)/setup.cache
i386-rtems-pc386-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
@@ -21,23 +34,14 @@ powerpc-rtems-mcp750-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
sh-rtems-gensh1-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
$(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems gensh1
-sh-rtemself-gensh1-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
- $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself gensh1
-
sparc-rtems-erc32-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
$(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems erc32
-TEMPLATES = rtems.spec.in
-
RPM_SPECS_DATA = i386-rtems-pc386-$(BSPVERS).spec \
m68k-rtems-gen68360-$(BSPVERS).spec powerpc-rtems-mcp750-$(BSPVERS).spec \
- sh-rtems-gensh1-$(BSPVERS).spec sh-rtemself-gensh1-$(BSPVERS).spec \
+ sh-rtems-gensh1-$(BSPVERS).spec \
sparc-rtems-erc32-$(BSPVERS).spec
-noinst_DATA = $(TEMPLATES)
-
-EXTRA_DIST = $(TEMPLATES)
-
-CLEANFILES = $(RPM_SPECS_DATA)
+CLEANFILES += $(RPM_SPECS_DATA)
include $(top_srcdir)/../automake/local.am