summaryrefslogtreecommitdiffstats
path: root/scripts/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-29 07:55:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-29 07:55:49 +0000
commit3d36fe3d826aa880ff80751a43fb06ee840a19b8 (patch)
treece073046ae3f171ccdf448f741eb970122ae6b6a /scripts/configure.ac
parent2002-07-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3d36fe3d826aa880ff80751a43fb06ee840a19b8.tar.bz2
2002-07-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Use AC_CONFIG_FILES(script, chmod +x script) to generate mk*spec scripts. * mkbspspec.in: Use ',' as pattern delimiter in sed expression for $rpm_build_root. * mkbinutilsspec.in: Use ',' as pattern delimiter in sed expression for $rpm_build_root. * cpukit/mkspec.in: Cosmetical changes.
Diffstat (limited to 'scripts/configure.ac')
-rw-r--r--scripts/configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/scripts/configure.ac b/scripts/configure.ac
index 3183da5a69..ef33954620 100644
--- a/scripts/configure.ac
+++ b/scripts/configure.ac
@@ -78,13 +78,6 @@ AC_SUBST(BSPVERS)
AC_SUBST(RPM_CPU)
AC_CONFIG_FILES([Makefile
-buildall
-buildalltar
-mkbinutilspec
-mkgccnewlibspec
-mkgcc3newlibspec
-mkgdbspec
-mkbspspec
binutils/Makefile
gccnewlib/Makefile
gcc3newlib/Makefile
@@ -94,7 +87,16 @@ autotools/Makefile
autotools/automake-rtems.spec
cpukit/Makefile
])
+
+AC_CONFIG_FILES([buildalltar],[chmod +x buildalltar])
+AC_CONFIG_FILES([buildall],[chmod +x buildall])
+AC_CONFIG_FILES([mkgdbspec],[chmod +x mkgdbspec])
+AC_CONFIG_FILES([mkbinutilspec],[chmod +x mkbinutilspec])
+AC_CONFIG_FILES([mkgccnewlibspec],[chmod +x mkgccnewlibspec])
+AC_CONFIG_FILES([mkgcc3newlibspec],[chmod +x mkgcc3newlibspec])
+AC_CONFIG_FILES([mkbspspec],[chmod +x mkbspspec])
AC_CONFIG_FILES([cpukit/mkspec],[chmod +x cpukit/mkspec])
+
AC_CONFIG_COMMANDS([default],[[chmod 755 buildall
chmod 755 buildalltar
]],[[]])