summaryrefslogtreecommitdiffstats
path: root/scripts-ada/gnatnewlib/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-13 16:35:55 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-13 16:35:55 +0000
commit1e3f4633a0f54977134a9b803e1737c4eac25cd5 (patch)
tree95c425ab2770177f5820dc7b297c1ad31f415a26 /scripts-ada/gnatnewlib/Makefile.am
parent2001-09-13 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-1e3f4633a0f54977134a9b803e1737c4eac25cd5.tar.bz2
2001-09-13 Joel Sherrill <joel@OARcorp.com>
* configure.in: Add RTEMS specific version of EXEEXT test. * mkgdbspec.in, mkgnatnewlibspec.in, gdb/gdb.spec.in, gnatnewlib/gnatnewlib.spec.in: Change to Target_alias to avoid conflicts with new autoconf/automake. * setup, setup.def, mkgnatnewlibspec.in: Add gnat_newlib_patch_version variable. * gnatnewlib/Makefile.am: Add i386-rtemscoff target in attempt to build it.
Diffstat (limited to 'scripts-ada/gnatnewlib/Makefile.am')
-rw-r--r--scripts-ada/gnatnewlib/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/scripts-ada/gnatnewlib/Makefile.am b/scripts-ada/gnatnewlib/Makefile.am
index 52232e9c4d..55203624cf 100644
--- a/scripts-ada/gnatnewlib/Makefile.am
+++ b/scripts-ada/gnatnewlib/Makefile.am
@@ -7,6 +7,9 @@ MKGNATNEWLIBSPEC = $(SHELL) $(top_builddir)/mkgnatnewlibspec
MKGNATNEWLIBSPEC_DEPS = $(top_builddir)/mkgnatnewlibspec gnatnewlib.spec.in \
$(top_builddir)/setup.cache
+i386-rtemscoff-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
+ $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtemscoff
+
powerpc-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
$(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems
@@ -15,7 +18,9 @@ sparc-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
TEMPLATES = gnatnewlib.spec.in
-RPM_SPECS_DATA = powerpc-rtems-$(GNATNEWLIBVERS).spec \
+RPM_SPECS_DATA = \
+ i386-rtemscoff-$(GNATNEWLIBVERS).spec \
+ powerpc-rtems-$(GNATNEWLIBVERS).spec \
sparc-rtems-$(GNATNEWLIBVERS).spec
noinst_DATA = $(TEMPLATES)