summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-04-26 18:05:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-04-26 18:05:33 +0000
commitfdbfff18679d1521fe289e2274d512c0cd67793d (patch)
treeba1c9b864685df04821505a93b60570b5399d140 /doc/user/Makefile.am
parentPatch rtemsdoc-4.5.0-rc-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-fdbfff18679d1521fe289e2274d512c0cd67793d.tar.bz2
Patches rtemsdoc-4.5.0-rc.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that addresses the following: The patch below should * fix the *pdf cleanup handling * fix dependencies between pdf-documents and texi-files It also contains an attempt to let networking/schedule.t use states.pdf instead of ascii graphics, but though each pdf image looks nice, it comes out weirdly distorted in the main pdf document.
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index fc81acf71c..04580543ab 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -26,6 +26,12 @@ info_TEXINFOS = c_user.texi
c_user_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
PNG_FILES = rtemsarc.png rtemspie.png states.png
+
+EPS_IMAGES = rtemspie.eps states.eps
+$(PROJECT).dvi: $(EPS_IMAGES)
+
+PDF_IMAGES = rtemspie.pdf states.pdf
+
if USE_HTML
html_project_DATA += $(PNG_FILES)
endif
@@ -151,7 +157,6 @@ mp.texi: mp.t
-n "Directive Status Codes" $<
noinst_DATA = \
-states.gif states.eps \
-rtemspie.gif rtemspie.eps
+states.gif rtemspie.gif
-EXTRA_DIST = *.t $(PNG_FILES) $(noinst_DATA)
+EXTRA_DIST = *.t $(PNG_FILES) $(EPS_IMAGES) $(noinst_DATA)