summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2006-09-13 16:21:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2006-09-13 16:21:09 +0000
commitaba8a85d4bd98a84d8e2b1e94bfb77fdd0b8a57e (patch)
tree425aca7cb19535d60a41a9c7ed2afd15f1ebb6ac /doc/user/Makefile.am
parentNew. (diff)
downloadrtems-aba8a85d4bd98a84d8e2b1e94bfb77fdd0b8a57e.tar.bz2
2006-09-13 Joel Sherrill <joel@OARcorp.com>
* new_chapters/Makefile.am, user/Makefile.am, user/c_user.texi, user/dirstat.texi, user/task.t: Move stack to first class citizen status. Include it in User Manual and rename to start with rtems_. * user/stackchk.t: New file. * new_chapters/stackchk.t: Removed.
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index 90182f51b4..8aaf34c041 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -17,7 +17,8 @@ FILES = bsp.texi dirstat.texi example.texi glossary.texi preface.texi
GENERATED_FILES = overview.texi concepts.texi datatypes.texi init.texi \
task.texi intr.texi clock.texi timer.texi sem.texi msg.texi event.texi \
signal.texi part.texi region.texi dpmem.texi io.texi fatal.texi \
- schedule.texi rtmon.texi bsp.texi userext.texi conf.texi mp.texi
+ schedule.texi rtmon.texi bsp.texi userext.texi conf.texi mp.texi \
+ stackchk.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
@@ -156,11 +157,16 @@ conf.texi: conf.t
mp.texi: mp.t
$(BMENU2) -p "Configuring a System Sizing the RTEMS RAM Workspace" \
-u "Top" \
+ -n "Stack Bounds Checker" < $< > $@
+
+stackchk.texi: stackchk.t
+ $(BMENU2) -p "Multiprocessing Manager MULTIPROCESSING_ANNOUNCE - Announce the arrival of a packet" \
+ -u "Top" \
-n "Directive Status Codes" < $< > $@
EXTRA_DIST = bsp.t concepts.t clock.t datatypes.t conf.t dpmem.t event.t \
fatal.t init.t intr.t io.t mp.t msg.t overview.t part.t region.t rtmon.t \
- sem.t schedule.t signal.t task.t timer.t userext.t $(TXT_FILES) $(PNG_FILES) \
- $(EPS_IMAGES) $(noinst_DATA)
+ sem.t schedule.t signal.t stackchk.t task.t timer.t userext.t \
+ $(TXT_FILES) $(PNG_FILES) $(EPS_IMAGES) $(noinst_DATA)
CLEANFILES += c_user.info c_user.info-? c_user.info-??