summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-09-20 01:06:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-09-20 01:06:48 +0000
commit3fb73e227bd7be768759b1a3dc054a564ce19cd0 (patch)
tree15130951d748fc1f7ec83511395815b55d951d1f /doc/user/Makefile.am
parent2011-09-19 Andrei Mozzhuhin <nopscmn@gmail.com> (diff)
downloadrtems-3fb73e227bd7be768759b1a3dc054a564ce19cd0.tar.bz2
2011-09-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* user/Makefile.am, user/c_user.texi: Reorder chapters to put scheduling earlier. Also put Barrier and Rate Monotonic Manager where they logically belong. They appear to have just be added toward the end.
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am41
1 files changed, 20 insertions, 21 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index 47c29b003b..847767dbab 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -1,5 +1,5 @@
#
-# COPYRIGHT (c) 1988-2007
+# COPYRIGHT (c) 1988-2011
# On-Line Applications Research Corporation (OAR).
# All rights reserved.
#
@@ -54,10 +54,15 @@ concepts.texi: concepts.t
datatypes.texi: datatypes.t
$(BMENU2) -p "Key Concepts Memory Management" \
-u "Top" \
+ -n "Scheduling Concepts" < $< > $@
+
+schedule.texi: schedule.t
+ $(BMENU2) -p "RTEMS Data Types List of Data Types" \
+ -u "Top" \
-n "Initialization Manager" < $< > $@
init.texi: init.t
- $(BMENU2) -p "RTEMS Data Types List of Data Types" \
+ $(BMENU2) -p "Scheduling Concepts Task State Transitions" \
-u "Top" \
-n "Task Manager" < $< > $@
@@ -80,15 +85,25 @@ clock.texi: clock.t
timer.texi: timer.t
$(BMENU2) -p "Clock Manager CLOCK_TICK - Announce a clock tick" \
-u "Top" \
+ -n "Rate Monotonic Manager" < $< > $@
+
+rtmon.texi: rtmon.t
+ $(BMENU2) -p "Timer Manager TIMER_RESET - Reset an interval timer" \
+ -u "Top" \
-n "Semaphore Manager" < $< > $@
sem.texi: sem.t
- $(BMENU2) -p "Timer Manager TIMER_RESET - Reset an interval timer" \
+ $(BMENU2) -p "Rate Monotonic Manager RATE_MONOTONIC_REPORT_STATISTICS - Print period statistics report" \
+ -u "Top" \
+ -n "Barrier Manager" < $< > $@
+
+barrier.texi: barrier.t
+ $(BMENU2) -p "Semaphore Manager SEMAPHORE_FLUSH - Unblock all tasks waiting on a semaphore" \
-u "Top" \
-n "Message Manager" < $< > $@
msg.texi: msg.t
- $(BMENU2) -p "Semaphore Manager SEMAPHORE_FLUSH - Unblock all tasks waiting on a semaphore" \
+ $(BMENU2) -p "Barrier Manager BARRIER_RELEASE - Release a barrier" \
-u "Top" \
-n "Event Manager" < $< > $@
@@ -128,26 +143,10 @@ io.texi: io.t
fatal.texi: fatal.t
$(BMENU2) -p "I/O Manager IO_CONTROL - Special device services" \
-u "Top" \
- -n "Scheduling Concepts" < $< > $@
-
-schedule.texi: schedule.t
- $(BMENU2) \
--p "Fatal Error Manager FATAL_ERROR_OCCURRED - Invoke the fatal error handler" \
- -u "Top" \
- -n "Rate Monotonic Manager" < $< > $@
-
-rtmon.texi: rtmon.t
- $(BMENU2) -p "Scheduling Concepts Task State Transitions" \
- -u "Top" \
- -n "Barrier Manager" < $< > $@
-
-barrier.texi: barrier.t
- $(BMENU2) -p "Rate Monotonic Manager RATE_MONOTONIC_REPORT_STATISTICS - Print period statistics report" \
- -u "Top" \
-n "Board Support Packages" < $< > $@
bsp.texi: bsp.t
- $(BMENU2) -p "Barrier Manager BARRIER_RELEASE - Release a barrier" \
+ $(BMENU2) -p "Fatal Error Manager FATAL_ERROR_OCCURRED - Invoke the fatal error handler" \
-u "Top" \
-n "User Extensions Manager" < $< > $@