summaryrefslogtreecommitdiffstats
path: root/doc/supplements/powerpc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-05-01 16:53:13 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-05-01 16:53:13 +0000
commita4ad94873205720065ae596cf3bbd52ad539bf7f (patch)
treee83067bfbcabd4e794f72d4a9e72b4c70ac5393e /doc/supplements/powerpc/Makefile.am
parentAdded on 4.5-branch (diff)
downloadrtems-a4ad94873205720065ae596cf3bbd52ad539bf7f.tar.bz2
Patch rtemsdoc-4.5.0-rc-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
It addresses: * .cvsignore (only minor changes to yours, as they were pretty clean, most changes result from my mkcvsignore script being overly pedantic sorting entries alphabetically.) * timing.t handling and time<BSP>_.texi handling in supplements * network.t handling in bsp_howto * RTEMS_DATE and RTEMS_UPDATE handling in configure.in. [It actually is a hack, as we could apply automake's version.texi handling instead - I know think to understand what automake does with it.] * avoid using temporary files; Therefore a new tool called bmenu2, derived from bemenu, is introduced, which reads a single file from stdin and writes to stdio. To apply: cd rtemsdoc patch -p1 < rtemsdoc-4.5.0-rc-3.diff cvs rm -f bsp_howto/network.t cvs add tools/bmenu/bmenu2.c ./bootstrap BTW: word-replace now is unused. It could be removed if you like to.
Diffstat (limited to 'doc/supplements/powerpc/Makefile.am')
-rw-r--r--doc/supplements/powerpc/Makefile.am28
1 files changed, 12 insertions, 16 deletions
diff --git a/doc/supplements/powerpc/Makefile.am b/doc/supplements/powerpc/Makefile.am
index 40a4dc2d3c..37b6bc324b 100644
--- a/doc/supplements/powerpc/Makefile.am
+++ b/doc/supplements/powerpc/Makefile.am
@@ -85,50 +85,46 @@ CLEANFILES += wksheets.t
# 1. Copy the Shared File
# 3. Build Node Structure
timing.texi: $(top_srcdir)/common/timing.t
- cp $(top_srcdir)/common/timing.t timing.t
- $(BMENU) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
+ $(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
-u "Top" \
- -n "PSIM Timing Data" timing.t
-CLEANFILES += timing.t
+ -n "PSIM Timing Data" < $< > $@
# Timing Data for PSIM BSP Chapter:
# 1. Copy the Shared File
# 2. Replace Times and Sizes
# 3. Build Node Structure
-timePSIM_.t: $(top_srcdir)/common/timetbl.t timePSIM.t
- cat timePSIM.t $(top_srcdir)/common/timetbl.t >timePSIM_.t
+timePSIM.texi: $(top_srcdir)/common/timetbl.t timePSIM.t
+ cat timePSIM.t $(top_srcdir)/common/timetbl.t >timePSIM_.t
@echo >>timePSIM_.t
@echo "@tex" >>timePSIM_.t
@echo "\\global\\advance \\smallskipamount by 4pt" >>timePSIM_.t
@echo "@end tex" >>timePSIM_.t
- ${REPLACE} -p PSIM_TIMES timePSIM_.t
- mv timePSIM_.t.fixed timePSIM_.t
-
-timePSIM.texi: timePSIM_.t
+ ${REPLACE2} -p PSIM_TIMES timePSIM_.t timePSIM_.t
$(BMENU) -p "Timing Specification Terminology" \
-u "Top" \
-n "DMV177 Timing Data" timePSIM_.t
mv timePSIM_.texi timePSIM.texi
+CLEANFILES += timePSIM_.t timePSIM_.texi
+
# Timing Data for DMV177 BSP Chapter:
# 1. Copy the Shared File
# 2. Replace Times and Sizes
# 3. Build Node Structure
-timeDMV177_.t: $(top_srcdir)/common/timetbl.t timeDMV177.t
- cat timeDMV177.t $(top_srcdir)/common/timetbl.t >timeDMV177_.t
+timeDMV177.texi: $(top_srcdir)/common/timetbl.t timeDMV177.t
+ cat timeDMV177.t $(top_srcdir)/common/timetbl.t >timeDMV177_.t
@echo >>timeDMV177_.t
@echo "@tex" >>timeDMV177_.t
@echo "\\global\\advance \\smallskipamount by 4pt" >>timeDMV177_.t
@echo "@end tex" >>timeDMV177_.t
- ${REPLACE} -p DMV177_TIMES timeDMV177_.t
- mv timeDMV177_.t.fixed timeDMV177_.t
-
-timeDMV177.texi: timeDMV177_.t
+ ${REPLACE2} -p DMV177_TIMES timeDMV177_.t timeDMV177_.t
$(BMENU) -p "PSIM Timing Data Rate Monotonic Manager" \
-u "Top" \
-n "Command and Variable Index" timeDMV177_.t
mv timeDMV177_.texi timeDMV177.texi
+CLEANFILES += timeDMV177_.t timeDMV177_.texi
+
EXTRA_DIST = DMV177_TIMES PSIM_TIMES *.t