summaryrefslogtreecommitdiffstats
path: root/doc/started/Makefile.am
diff options
context:
space:
mode:
authorGedare Bloom <gedare@rtems.org>2015-03-11 10:29:13 -0400
committerGedare Bloom <gedare@rtems.org>2015-03-11 13:39:29 -0400
commitd84995d28c141fd6eb0f04606ea35caa316b9eb7 (patch)
tree8457e82327fd512769d2140a6393ae42b2926795 /doc/started/Makefile.am
parentcpukit: deprecate task variables. closes #2293. (diff)
downloadrtems-d84995d28c141fd6eb0f04606ea35caa316b9eb7.tar.bz2
doc/started: simplify and fix
* fix and remove some macros in rtems.texi.in. * refer to devel mailing list. * remove reference to Debian packaging in requirements section. * remove section on prebuilt tools. * replace toolset build instructions with link to RSB docs. * Add a note in building RTEMS section about using RSB. * Fix URLs Closes #2291.
Diffstat (limited to 'doc/started/Makefile.am')
-rw-r--r--doc/started/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/doc/started/Makefile.am b/doc/started/Makefile.am
index df74da3b1a..0eef621ffd 100644
--- a/doc/started/Makefile.am
+++ b/doc/started/Makefile.am
@@ -8,7 +8,7 @@ PROJECT = started
include $(top_srcdir)/project.am
include $(top_srcdir)/main.am
-GENERATED_FILES = binaries.texi buildc.texi buildrt.texi intro.texi nt.texi \
+GENERATED_FILES = buildc.texi buildrt.texi intro.texi nt.texi \
require.texi nextstep.texi sample.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
@@ -24,23 +24,19 @@ intro.texi: intro.t
-n "Requirements" < $< > $@
require.texi: require.t
- $(BMENU2) -c -p "GCC Mailing Lists" \
+ $(BMENU2) -c -p "RTEMS Mailing Lists" \
-u "Top" \
- -n "Prebuilt Toolset Executables" < $< > $@
-
-binaries.texi: binaries.t
- $(BMENU2) -c \
- -p "GNU/Linux Distributions using Debian Packaging Format" \
- -u "Top" \
- -n "Building the GNU Cross Compiler Toolset" < $< > $@
+ -n "Building the GNU Cross Compiler Toolset with RSB" < $< > $@
buildc.texi: buildc.t
- $(BMENU2) -c -p "Removing Zipped Tar Files" \
+ $(BMENU2) -c \
+ -p "Distribution Independent Potential GNU/Linux Issues" \
-u "Top" \
-n "Building RTEMS" < $< > $@
buildrt.texi: buildrt.t
- $(BMENU2) -c -p "Error Messages Indicating Configuration Problems" \
+ $(BMENU2) -c \
+ -p "Building the GNU Cross Compiler Toolset with RSB" \
-u "Top" \
-n "Building the Sample Applications" < $< > $@
@@ -59,7 +55,7 @@ nt.texi: nt.t
-u "Top" \
-n "" < $< > $@
-EXTRA_DIST = binaries.t buildc.t buildrt.t intro.t nextstep.t nt.t require.t \
+EXTRA_DIST = buildc.t buildrt.t intro.t nextstep.t nt.t require.t \
sample.t
if USE_HTML