summaryrefslogtreecommitdiffstats
path: root/doc/shell/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-02-20 22:55:13 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-02-20 22:55:13 +0000
commiteb03905dfea70134f357914e6c590340aca9bba3 (patch)
treecc1be457a8099b3f3dff49c823deaaa5558653e2 /doc/shell/Makefile.am
parent2008-02-20 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-eb03905dfea70134f357914e6c590340aca9bba3.tar.bz2
2008-02-20 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, index.html.in: Add initial version of RTEMS Shell Manual. This is largely a starting point but has most of the required structure. * shell/.cvsignore, shell/Makefile.am, shell/file.t, shell/general.t, shell/memory.t, shell/network.t, shell/preface.texi, shell/rtems.t, shell/shell.texi: New files.
Diffstat (limited to 'doc/shell/Makefile.am')
-rw-r--r--doc/shell/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/doc/shell/Makefile.am b/doc/shell/Makefile.am
new file mode 100644
index 0000000000..506fd6b4e5
--- /dev/null
+++ b/doc/shell/Makefile.am
@@ -0,0 +1,51 @@
+#
+# COPYRIGHT (c) 1988-2007
+# On-Line Applications Research Corporation (OAR).
+# All rights reserved.
+#
+# $Id$
+#
+
+PROJECT = shell
+EDITION = 1
+
+include $(top_srcdir)/project.am
+include $(top_srcdir)/main.am
+
+FILES = shell.texi preface.texi
+
+GENERATED_FILES = general.texi file.texi memory.texi rtems.texi network.texi
+
+COMMON_FILES += $(top_srcdir)/common/cpright.texi
+
+info_TEXINFOS = shell.texi
+shell_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+general.texi: general.t
+ $(BMENU2) -p "Preface" \
+ -u "Top" \
+ -n "" < $< > $@
+
+file.texi: file.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
+memory.texi: memory.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
+rtems.texi: rtems.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
+network.texi: network.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
+EXTRA_DIST = general.t file.t memory.t rtems.t network.t
+
+CLEANFILES += shell.info shell.info-? shell.info-??