summaryrefslogtreecommitdiffstats
path: root/doc/shell/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-02-29 00:23:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-02-29 00:23:04 +0000
commitc2153cfd292dbb771bcbff034284c30edff55f28 (patch)
tree28512ff947edfad7afcdf1be225dc13d5cae3c46 /doc/shell/Makefile.am
parent2008-02-28 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-c2153cfd292dbb771bcbff034284c30edff55f28.tar.bz2
2008-02-28 Joel Sherrill <joel.sherrill@oarcorp.com>
* shell/.cvsignore, shell/Makefile.am, shell/memory.t, shell/preface.texi, shell/shell.texi: Added much information the Preface. Created initial version of Configuration and Intialization chapter. Links are now complete from start to end of manual. * shell/confinit.t: New file.
Diffstat (limited to 'doc/shell/Makefile.am')
-rw-r--r--doc/shell/Makefile.am28
1 files changed, 17 insertions, 11 deletions
diff --git a/doc/shell/Makefile.am b/doc/shell/Makefile.am
index 506fd6b4e5..8e13f23383 100644
--- a/doc/shell/Makefile.am
+++ b/doc/shell/Makefile.am
@@ -14,37 +14,43 @@ include $(top_srcdir)/main.am
FILES = shell.texi preface.texi
-GENERATED_FILES = general.texi file.texi memory.texi rtems.texi network.texi
+GENERATED_FILES = confinit.texi general.texi file.texi memory.texi \
+ rtems.texi network.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
info_TEXINFOS = shell.texi
shell_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
-general.texi: general.t
+confinit.texi: confinit.t
$(BMENU2) -p "Preface" \
-u "Top" \
- -n "" < $< > $@
+ -n "General Commands" < $< > $@
+
+general.texi: general.t
+ $(BMENU2) -p "Configuration and Initialization rtems_shell_init - initialize the shell" \
+ -u "Top" \
+ -n "File and Directory Commands" < $< > $@
file.texi: file.t
- $(BMENU2) -p "" \
+ $(BMENU2) -p "General Commands exit - exit the shell" \
-u "Top" \
- -n "" < $< > $@
+ -n "Memory Commands" < $< > $@
memory.texi: memory.t
- $(BMENU2) -p "" \
+ $(BMENU2) -p "File and Directory Commands cd - alias for chdir" \
-u "Top" \
- -n "" < $< > $@
+ -n "RTEMS Specific Commands" < $< > $@
rtems.texi: rtems.t
- $(BMENU2) -p "" \
+ $(BMENU2) -p "Memory Commands malloc - obtain information on C program heap" \
-u "Top" \
- -n "" < $< > $@
+ -n "Network Commands" < $< > $@
network.texi: network.t
- $(BMENU2) -p "" \
+ $(BMENU2) -p "RTEMS Specific Commands dname - displays information about named drivers" \
-u "Top" \
- -n "" < $< > $@
+ -n "Function and Variable Index" < $< > $@
EXTRA_DIST = general.t file.t memory.t rtems.t network.t