summaryrefslogtreecommitdiffstats
path: root/doc/filesystem/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/filesystem/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to 'doc/filesystem/Makefile.am')
-rw-r--r--doc/filesystem/Makefile.am65
1 files changed, 32 insertions, 33 deletions
diff --git a/doc/filesystem/Makefile.am b/doc/filesystem/Makefile.am
index 5b02ed1d39..84d7344eed 100644
--- a/doc/filesystem/Makefile.am
+++ b/doc/filesystem/Makefile.am
@@ -6,63 +6,62 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=filesystem
+PROJECT = filesystem
+EDITION = 1
include $(top_srcdir)/project.am
-BMENU+= -c
+BMENU2 += -c
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = patheval.texi init.texi mounting.texi syscalls.texi \
+ fsrequirements.texi imfs.texi miniimfs.texi tftp.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-GENERATED_FILES=patheval.texi \
- init.texi mounting.texi syscalls.texi fsrequirements.texi imfs.texi \
- miniimfs.texi tftp.texi
-
-FILES= preface.texi
+FILES = preface.texi
info_TEXINFOS = filesystem.texi
filesystem_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
-patheval.texi: patheval.t
- $(BMENU) -p "" \
+$(srcdir)/patheval.texi: patheval.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-init.texi: init.t
- $(BMENU) -p "" \
+$(srcdir)/init.texi: init.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-mounting.texi: mounting.t
- $(BMENU) -p "" \
+$(srcdir)/mounting.texi: mounting.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-syscalls.texi: syscalls.t
- $(BMENU) -p "" \
+$(srcdir)/syscalls.texi: syscalls.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-fsrequirements.texi: fsrequirements.t
- $(BMENU) -p "" \
+$(srcdir)/fsrequirements.texi: fsrequirements.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-imfs.texi: imfs.t
- $(BMENU) -p "" \
+$(srcdir)/imfs.texi: imfs.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-miniimfs.texi: miniimfs.t
- $(BMENU) -p "" \
+$(srcdir)/miniimfs.texi: miniimfs.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-tftp.texi: tftp.t
- $(BMENU) -p "" \
+$(srcdir)/tftp.texi: tftp.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
EXTRA_DIST = *.t