summaryrefslogtreecommitdiffstats
path: root/doc/cpu_supplement/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2012-06-11 13:37:29 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2012-06-11 13:37:29 -0500
commit2d7ae960bbdbc82f795814ee6c600e93200ddf4d (patch)
treead12bf1ac7f551a70f004a897a7246cf0b9ea716 /doc/cpu_supplement/Makefile.am
parentpowerpc/cpu.h: Define CPU_SIMPLE_VECTORED_INTERRUPTS and remove _CPU_ISR_Init... (diff)
downloadrtems-2d7ae960bbdbc82f795814ee6c600e93200ddf4d.tar.bz2
v850 port: Initial addition with BSP for simulator in GDB
Port + v850 does not have appear to have any optimized bit scan instructions + v850 does have single instructions for wap u16 and u32 + Code path optimization preferences set + Add BSP variants for each GCC CPU model flag and a README - v850e1 variant does not work (fails during BSP initialization) BSP for GDB v850 Simulator + linkcmds matches defaults in GDB simulator with RTEMS mods + crt1.c added from v850 newlib port for __main() + BSP exits cleanly + printk and console I/O work + uses clock tick from IDLE task + Tests not requiring real clock ISR work Documentation + CPU Supplment chapter for v850 added
Diffstat (limited to 'doc/cpu_supplement/Makefile.am')
-rw-r--r--doc/cpu_supplement/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/doc/cpu_supplement/Makefile.am b/doc/cpu_supplement/Makefile.am
index 970ea7a6f9..8d117cfcd0 100644
--- a/doc/cpu_supplement/Makefile.am
+++ b/doc/cpu_supplement/Makefile.am
@@ -1,5 +1,5 @@
#
-# COPYRIGHT (c) 1988-2002.
+# COPYRIGHT (c) 1988-2012.
# On-Line Applications Research Corporation (OAR).
# All rights reserved.
@@ -11,7 +11,7 @@ include $(top_srcdir)/main.am
REPLACE2 = $(PERL) $(top_srcdir)/tools/word-replace2
GENERATED_FILES = general.texi arm.texi avr.texi bfin.texi i386.texi lm32.texi \
- m68k.texi mips.texi powerpc.texi sh.texi sparc.texi sparc64.texi
+ m68k.texi mips.texi powerpc.texi sh.texi sparc.texi sparc64.texi v850.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
@@ -84,6 +84,11 @@ sparc64.texi: sparc64.t
-u "Top" \
-n "" < $< > $@
+v850.texi: v850.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
CLEANFILES += cpu_supplement.info
CLEANFILES += cpu_supplement.info-1
CLEANFILES += cpu_supplement.info-2