summaryrefslogtreecommitdiffstats
path: root/doc/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-18 15:10:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-18 15:10:54 +0000
commit21e473b0b061fb10d47319ed8607e2b8d1e7efc4 (patch)
tree89df20c089f9aaf883eacd281e1b7de93dc939b4 /doc/configure.ac
parent2002-01-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-21e473b0b061fb10d47319ed8607e2b8d1e7efc4.tar.bz2
2002-01-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Require automake-1.5. * project.am: Reworked. * main.am: New. * configure.ac: New. * configure.in: Removed. * bootstrap: Sync with RTEMS's toplevel bootstrap.sh.
Diffstat (limited to 'doc/configure.ac')
-rw-r--r--doc/configure.ac171
1 files changed, 171 insertions, 0 deletions
diff --git a/doc/configure.ac b/doc/configure.ac
new file mode 100644
index 0000000000..d4ed9905a9
--- /dev/null
+++ b/doc/configure.ac
@@ -0,0 +1,171 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.52)
+
+AC_INIT
+AC_CONFIG_SRCDIR([project.am])
+
+RTEMS_VERSION=4.5.0-beta3
+
+AM_INIT_AUTOMAKE(rtemsdoc,${RTEMS_VERSION},no)
+AM_MAINTAINER_MODE
+
+AC_ARG_ENABLE(html,
+[ --disable-html disable html support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_html="yes"]
+)
+
+AC_ARG_ENABLE(dvi,
+[ --disable-dvi disable dvi support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_dvi="yes"]
+)
+
+AC_ARG_ENABLE(pdf,
+[ --disable-pdf disable pdf support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_pdf="yes"]
+)
+
+AC_ARG_ENABLE(ps,
+[ --disable-ps disable ps support ],
+[case $enableval in
+yes) ;;
+no) ;;
+*) AC_MSG_ERROR("invalid value");;
+esac],
+[enable_ps="yes"]
+)
+
+AC_ARG_ENABLE(papersize,
+[ --enable-papersize=[letter|a4|] set papersize [default:system defaults]],
+[case $enableval in
+a4) papersize=a4 ;;
+letter) papersize=letter ;;
+yes) papersize= ;;
+no) papersize= ;;
+*) AC_MSG_ERROR([Invalid papersize])
+;;
+esac],
+[papersize=]
+)
+
+htmldir='$(pkgdatadir)/html'
+AC_SUBST(htmldir)
+
+dnl Checks for programs.
+AC_PROG_LN_S
+
+AC_CHECK_PROGS(PERL,perl)
+
+TEXI2WWW='$(PERL) $(top_srcdir)/tools/texi2www/texi2www'
+AC_SUBST(TEXI2WWW)
+
+AC_CHECK_PROGS(GS,gs)
+AM_CONDITIONAL(GS,test x"$GS" != x"")
+
+AC_CHECK_PROGS(TEXI2DVI,texi2dvi)
+AM_CONDITIONAL(TEXI2DVI,test x"$TEXI2DVI" != x"")
+if test "$enable_pdf" = "yes"; then
+ AC_CHECK_PROGS(EPSTOPDF,epstopdf)
+ AM_CONDITIONAL(EPSTOPDF,test x"$EPSTOPDF" != x"")
+
+ AC_CHECK_PROGS(TEXI2PDF,texi2pdf)
+ AM_CONDITIONAL(TEXI2PDF,test x"$TEXI2PDF" != x"")
+fi
+
+AM_CONDITIONAL(USE_HTML,
+ test "$enable_html" = "yes" \
+ && test x"PERL" != x"" )
+
+AM_CONDITIONAL(USE_DVI,
+ test "$enable_dvi" = "yes" \
+ && test x"$TEXI2DVI" != x"" )
+
+AM_CONDITIONAL(USE_PS,
+ test "$enable_ps" = "yes" \
+ && test x"$TEXI2DVI" != x"" )
+
+AM_CONDITIONAL(USE_PDF,
+ test "$enable_pdf" = "yes" \
+ && test x"$TEXI2DVI" != x"" \
+ && test x"$TEXI2PDF" != x"" )
+
+case $papersize in
+a4)
+ TEXI2DVI="${TEXI2DVI} --texinfo=@afourpaper"
+ TEXI2PDF="${TEXI2PDF} --texinfo=@afourpaper"
+ DVIPS="dvips -t a4"
+;;
+letter)
+ DVIPS="dvips -t letter"
+ ;;
+*)
+ DVIPS="dvips"
+;;
+esac
+AC_SUBST(DVIPS)
+
+BMENU2='$(top_builddir)/tools/bmenu/bmenu2'
+AC_SUBST(BMENU2)
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+dnl Checks for library functions.
+
+AC_CONFIG_SUBDIRS(tools)
+
+AC_CONFIG_FILES([Makefile
+rtems_support.html
+index.html
+images/Makefile
+common/Makefile
+FAQ/Makefile
+develenv/Makefile
+user/Makefile
+bsp_howto/Makefile
+started/Makefile
+started/pictures/Makefile
+porting/Makefile
+networking/Makefile
+posix_users/Makefile
+posix1003.1/Makefile
+filesystem/Makefile
+itron3.0/Makefile
+ada_user/Makefile
+started_ada/Makefile
+rtems_gdb/Makefile
+rgdb_specs/Makefile
+relnotes/Makefile
+new_chapters/Makefile
+supplements/Makefile
+supplements/hppa1_1/Makefile
+supplements/i386/Makefile
+supplements/i960/Makefile
+supplements/m68k/Makefile
+supplements/mips64orion/Makefile
+supplements/powerpc/Makefile
+supplements/sh/Makefile
+supplements/sparc/Makefile
+supplements/template/Makefile
+gnu_docs/Makefile
+src2html/Makefile
+])
+AC_OUTPUT