summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 07:35:52 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 07:35:52 +0000
commit7d0eba022a72276f82c7aee9a4b919a9606247a1 (patch)
treef17056719911431651f47357c84ca9d6d35bf0af /cpukit/score/cpu/unix/Makefile.am
parent2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7d0eba022a72276f82c7aee9a4b919a9606247a1.tar.bz2
2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add $(dirstamp) to preinstallation rules.
Diffstat (limited to 'cpukit/score/cpu/unix/Makefile.am')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
index 12fb64edff..34a5e275ee 100644
--- a/cpukit/score/cpu/unix/Makefile.am
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -29,24 +29,25 @@ EXTRA_DIST = cpu.c
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/rtems/score:
+$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score
+ @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/types.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
-$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
-$(PROJECT_INCLUDE)/rtems/score/unix.h: rtems/score/unix.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/unix.h: rtems/score/unix.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/unix.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/unix.h
-$(PROJECT_INCLUDE)/rtems/score/unixsize.h: rtems/score/unixsize.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/unixsize.h: rtems/score/unixsize.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/unixsize.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/unixsize.h
include $(top_srcdir)/../../../automake/local.am