summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sparc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-03-12 06:37:36 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-03-13 08:05:39 +0100
commit8b5778e69e7fc8393f7e192067116da09aec71df (patch)
treecff7165b703d5f6dd612acc1a4b073e5bcc4c521 /cpukit/score/cpu/sparc/Makefile.am
parentbsps/arm: Move libcpu content to bsps (diff)
downloadrtems-8b5778e69e7fc8393f7e192067116da09aec71df.tar.bz2
sparc: Move libcpu content to cpukit
This patch is a part of the BSP source reorganization. Update #3285.
Diffstat (limited to 'cpukit/score/cpu/sparc/Makefile.am')
-rw-r--r--cpukit/score/cpu/sparc/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/cpukit/score/cpu/sparc/Makefile.am b/cpukit/score/cpu/sparc/Makefile.am
index 1a76a2f009..817cc11741 100644
--- a/cpukit/score/cpu/sparc/Makefile.am
+++ b/cpukit/score/cpu/sparc/Makefile.am
@@ -1,12 +1,16 @@
include $(top_srcdir)/automake/compile.am
noinst_LIBRARIES = libscorecpu.a
-libscorecpu_a_SOURCES = cpu.c
-libscorecpu_a_SOURCES += sparc-context-volatile-clobber.S
+libscorecpu_a_SOURCES =
+libscorecpu_a_SOURCES += access_le.c
+libscorecpu_a_SOURCES += access.S
+libscorecpu_a_SOURCES += cpu.c
libscorecpu_a_SOURCES += sparc-context-validate.S
-libscorecpu_a_SOURCES += sparc-counter.c
+libscorecpu_a_SOURCES += sparc-context-volatile-clobber.S
libscorecpu_a_SOURCES += sparc-counter-asm.S
-libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+libscorecpu_a_SOURCES += sparc-counter.c
+libscorecpu_a_SOURCES += syscall.S
+libscorecpu_a_SOURCES += window.S
include $(top_srcdir)/automake/local.am
include $(srcdir)/headers.am