summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-23 10:36:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-23 10:36:05 +0000
commitd6a444d3b3707ceba558bfbd276289de152b9b69 (patch)
tree158158d6b40c6393d724207d6fd6f482a1a62573 /cpukit/score/cpu/powerpc/Makefile.am
parent2003-11-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d6a444d3b3707ceba558bfbd276289de152b9b69.tar.bz2
2003-11-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Don't use gmake rules for preinstallation.
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am85
1 files changed, 47 insertions, 38 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index e77b61d4d6..134ac7d868 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -8,58 +8,21 @@ include $(top_srcdir)/../../../automake/multilib.am
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/score:
- $(mkinstalldirs) $@
-
include_HEADERS = asm.h
-PREINSTALL_FILES = $(PROJECT_INCLUDE) \
- $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = \
- rtems/score/ppc.h \
- rtems/score/types.h
+include_rtems_score_HEADERS = rtems/score/ppc.h rtems/score/types.h
include_rtems_score_HEADERS += rtems/score/cpu.h
-$(PROJECT_INCLUDE)/rtems/old-exceptions:
- $(mkinstalldirs) $@
-
include_rtems_old_exceptionsdir = $(includedir)/rtems/old-exceptions
include_rtems_old_exceptions_HEADERS = rtems/old-exceptions/cpu.h
-$(PROJECT_INCLUDE)/rtems/new-exceptions:
- $(mkinstalldirs) $@
-
include_rtems_new_exceptionsdir = $(includedir)/rtems/new-exceptions
include_rtems_new_exceptions_HEADERS = rtems/new-exceptions/cpu.h
-$(PROJECT_INCLUDE)/rtems/powerpc:
- $(mkinstalldirs) $@
-
include_rtems_powerpcdir = $(includedir)/rtems/powerpc
include_rtems_powerpc_HEADERS = rtems/powerpc/registers.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions \
- $(include_rtems_old_exceptions_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions \
- $(include_rtems_new_exceptions_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc \
- $(include_rtems_powerpc_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
C_FILES = # cpu.c
OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
@@ -72,4 +35,50 @@ $(LIB): $(OBJS)
all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB) \
$(TMPINSTALL_FILES)
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/asm.h: asm.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
+
+$(PROJECT_INCLUDE)/rtems/score:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score
+
+$(PROJECT_INCLUDE)/rtems/score/ppc.h: rtems/score/ppc.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ppc.h
+
+$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
+
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/old-exceptions:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/old-exceptions
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions
+
+$(PROJECT_INCLUDE)/rtems/old-exceptions/cpu.h: rtems/old-exceptions/cpu.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/new-exceptions:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/new-exceptions
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions
+
+$(PROJECT_INCLUDE)/rtems/new-exceptions/cpu.h: rtems/new-exceptions/cpu.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/powerpc:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/powerpc
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc
+
+$(PROJECT_INCLUDE)/rtems/powerpc/registers.h: rtems/powerpc/registers.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc/registers.h
+
include $(top_srcdir)/../../../automake/local.am