summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-04-13 09:45:15 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-04-13 09:45:15 +0000
commitb6bf7d535ec27a5c5e82a58705d103e8ba381588 (patch)
tree31a5968e917d318b0922c23e15054f464d6d1e7d /cpukit/score/cpu/powerpc/Makefile.am
parent2004-04-12 David Querbach <querbach@realtime.bc.ca> (diff)
downloadrtems-b6bf7d535ec27a5c5e82a58705d103e8ba381588.tar.bz2
2004-04-13 Ralf Corsepius <ralf_corsepius@rtems.org>
* rtems/score/powerpc.h: New (Copied and renamed from rtems/score/ppc.h) for consistency with other ports. * rtems/score/ppc.h: Deprecation wrapper to rtems/score/powerpc.h. * Makefile.am: Reflect changes above. * rtems/score/cpu.h: Include rtems/score/powerpc.h instead of rtems/score/ppc.h.
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am25
1 files changed, 17 insertions, 8 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index aaad49c43b..64d8ceb878 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -8,8 +8,11 @@ include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = asm.h
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = rtems/score/ppc.h rtems/score/types.h
-include_rtems_score_HEADERS += rtems/score/cpu.h
+include_rtems_score_HEADERS = rtems/score/powerpc.h rtems/score/cpu.h \
+ rtems/score/types.h
+if DEPRECATED
+include_rtems_score_HEADERS += rtems/score/ppc.h
+endif
include_rtems_old_exceptionsdir = $(includedir)/rtems/old-exceptions
include_rtems_old_exceptions_HEADERS = rtems/old-exceptions/cpu.h
@@ -39,17 +42,23 @@ $(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-$(PROJECT_INCLUDE)/rtems/score/ppc.h: rtems/score/ppc.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ppc.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ppc.h
+$(PROJECT_INCLUDE)/rtems/score/powerpc.h: rtems/score/powerpc.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/powerpc.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/powerpc.h
+
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/types.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
-$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
+if DEPRECATED
+$(PROJECT_INCLUDE)/rtems/score/ppc.h: rtems/score/ppc.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ppc.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ppc.h
+endif
$(PROJECT_INCLUDE)/rtems/old-exceptions/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/old-exceptions