summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-26 13:32:13 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-26 13:32:13 +0000
commita85d8ecbb71c5f1950407b6adfe0fabba3cb523a (patch)
treee5f6fb33d3132b0cb1e26cdb64a29b39397d0ca3 /cpukit/score/cpu/powerpc/Makefile.am
parent2002-07-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a85d8ecbb71c5f1950407b6adfe0fabba3cb523a.tar.bz2
2002-07-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Build libscorecpu.a instead of rtems-cpu.rel.
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index 6a99da25fb..b69bac7395 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -42,7 +42,6 @@ $(PROJECT_INCLUDE)/rtems/new-exceptions:
include_rtems_new_exceptionsdir = $(includedir)/rtems/new-exceptions
include_rtems_new_exceptions_HEADERS = rtems/new-exceptions/cpu.h
-
$(PROJECT_INCLUDE)/rtems/powerpc:
$(mkinstalldirs) $@
@@ -61,16 +60,18 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions \
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc \
$(include_rtems_powerpc_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-# $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).$(OBJEXT): $(ARCH)/rtems.$(OBJEXT)
-# $(INSTALL_DATA) $< $@
+C_FILES = # cpu.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-# $(REL): $(rtems_cpu_rel_OBJECTS)
-# $(make-rel)
+S_FILES = # cpu_asm.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
+libscorecpu_a_OBJECTS = $(C_O_FILES) $(S_O_FILES)
-# TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).$(OBJEXT)
+$(LIB): $(libscorecpu_a_OBJECTS)
+ $(make-library)
-all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
+all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB) \
$(TMPINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am