summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-05-07 10:14:55 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-05-10 12:10:14 +0200
commit39993d6d7693b9fd26d729efd199cc605cd2ae65 (patch)
treed06b29ef4cd1d68223c25e9de9069b445bf4aed1 /cpukit/score/cpu/powerpc/Makefile.am
parentarm: Add FUNCTION_THUMB_ENTRY(), etc. (diff)
downloadrtems-39993d6d7693b9fd26d729efd199cc605cd2ae65.tar.bz2
score: Add CPU context validation
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index 7fd64ef7cf..b205762674 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -14,6 +14,8 @@ include_rtems_powerpc_HEADERS = rtems/powerpc/registers.h
noinst_LIBRARIES = libscorecpu.a
libscorecpu_a_SOURCES = cpu.c
+libscorecpu_a_SOURCES += ppc-context-volatile-clobber.S
+libscorecpu_a_SOURCES += ppc-context-validate.S
libscorecpu_a_SOURCES += ppc-isr-vector-install.c
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)