summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/or1k/Makefile.am
diff options
context:
space:
mode:
authorHesham ALMatary <heshamelmatary@gmail.com>2014-08-31 18:29:41 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-09-02 09:29:08 -0500
commit305357eda5cc68436140a86379443ae4873f32e1 (patch)
tree7a23ace6a17c0bbd6337d5157ba6775f3bc36673 /cpukit/score/cpu/or1k/Makefile.am
parentAdd missing r31 load instruction _ISR_Handler (diff)
downloadrtems-305357eda5cc68436140a86379443ae4873f32e1.tar.bz2
or1k: Implement context validate and context volatile clobber functions.
score/cpu/or1k: Add two new assembly functions: _CPU_Context_validate and _CPU_Context_volatile_clobber; their implementation follows corresponding ARM functions.
Diffstat (limited to 'cpukit/score/cpu/or1k/Makefile.am')
-rw-r--r--cpukit/score/cpu/or1k/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/score/cpu/or1k/Makefile.am b/cpukit/score/cpu/or1k/Makefile.am
index cb9685619d..b9e00d3634 100644
--- a/cpukit/score/cpu/or1k/Makefile.am
+++ b/cpukit/score/cpu/or1k/Makefile.am
@@ -24,6 +24,8 @@ libscorecpu_a_SOURCES =
libscorecpu_a_SOURCES += cpu.c
libscorecpu_a_SOURCES += or1k-context-switch.S
libscorecpu_a_SOURCES += or1k-context-initialize.c
+libscorecpu_a_SOURCES += or1k-context-validate.S
+libscorecpu_a_SOURCES += or1k-context-volatile-clobber.S
libscorecpu_a_SOURCES += or1k-exception-default.c
libscorecpu_a_SOURCES += or1k-exception-frame-print.c
libscorecpu_a_SOURCES += or1k-exception-handler-low.S