summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/or16/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-07-31 13:30:43 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-07-31 13:30:43 +0000
commit35b063305a6b5132f69a092e9d854f23b836f906 (patch)
treef184b2683a3f8c1b2abde52f576d9458ce625780 /cpukit/score/cpu/or16/Makefile.am
parent2002-07-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-35b063305a6b5132f69a092e9d854f23b836f906.tar.bz2
2002-07-31 Joel Sherrill <joel@OARcorp.com>
* .cvsignore, ChangeLog, asm.h, configure.ac, cpu.c, cpu_asm.c, rtems/score/.cvsignore, rtems/score/cpu.h, rtems/score/cpu_asm.h, rtems/score/or16.h, rtems/score/types.h: Removed as the or16 port was just a stub and only the OR32 port is getting worked on.
Diffstat (limited to 'cpukit/score/cpu/or16/Makefile.am')
-rw-r--r--cpukit/score/cpu/or16/Makefile.am50
1 files changed, 0 insertions, 50 deletions
diff --git a/cpukit/score/cpu/or16/Makefile.am b/cpukit/score/cpu/or16/Makefile.am
deleted file mode 100644
index 34a69b1a57..0000000000
--- a/cpukit/score/cpu/or16/Makefile.am
+++ /dev/null
@@ -1,50 +0,0 @@
-##
-## $Id$
-##
-
-ACLOCAL_AMFLAGS = -I ../../../aclocal
-
-include $(top_srcdir)/../../../automake/multilib.am
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/score:
- $(mkinstalldirs) $@
-
-include_HEADERS= asm.h
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = \
- rtems/score/cpu.h \
- rtems/score/types.h \
- rtems/score/or16.h \
- rtems/score/cpu_asm.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
-C_FILES = cpu.c cpu_asm.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-LIB = $(ARCH)/libscorecpu.a
-
-libscorecpu_a_OBJECTS = $(C_O_FILES)
-
-$(LIB): $(libscorecpu_a_OBJECTS)
- $(make-library)
-
-all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB) \
- $(TMPINSTALL_FILES)
-
-EXTRA_DIST = cpu.c cpu_asm.c
-
-include $(top_srcdir)/../../../automake/local.am