summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/nios2/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2011-08-09 11:11:30 +0000
committerSebastian Huber <sebastian.huber@embedded-brains.de>2011-08-09 11:11:30 +0000
commit3ee5a2e29b8e96239256130447374eef55d74970 (patch)
tree5117bde76246c4ed74cde6e324c6325d05bdf27c /cpukit/score/cpu/nios2/Makefile.am
parent2011-08-09 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-3ee5a2e29b8e96239256130447374eef55d74970.tar.bz2
2011-08-09 Sebastian Huber <sebastian.huber@embedded-brains.de>
* nios2-iic-low-level.S: New file. * cpu_asm.S: Moved low-level interrupt handling into new file. * Makefile.am: Reflect change from above.
Diffstat (limited to 'cpukit/score/cpu/nios2/Makefile.am')
-rw-r--r--cpukit/score/cpu/nios2/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/cpukit/score/cpu/nios2/Makefile.am b/cpukit/score/cpu/nios2/Makefile.am
index 2004daa2f3..2921813434 100644
--- a/cpukit/score/cpu/nios2/Makefile.am
+++ b/cpukit/score/cpu/nios2/Makefile.am
@@ -17,7 +17,10 @@ include_rtems_score_HEADERS += rtems/score/cpu_asm.h
include_rtems_score_HEADERS += rtems/score/types.h
noinst_LIBRARIES = libscorecpu.a
-libscorecpu_a_SOURCES = cpu.c irq.c cpu_asm.S
+libscorecpu_a_SOURCES = cpu.c \
+ irq.c \
+ nios2-iic-low-level.S \
+ cpu_asm.S
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
all-local: $(PREINSTALL_FILES)