summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/m32c/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-10-02 21:32:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-10-02 21:32:44 +0000
commited6e94718057565c287a28d186d06816b74c65cf (patch)
tree7f83b4da2f2d9111ef37b266c892ebcd8373dc20 /cpukit/score/cpu/m32c/Makefile.am
parent2008-10-02 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-ed6e94718057565c287a28d186d06816b74c65cf.tar.bz2
2008-10-02 Joel Sherrill <joel.sherrill@oarcorp.com>
* .cvsignore, ChangeLog, Makefile.am, context_init.c, context_switch.S, cpu.c, cpu_asm.c, preinstall.am, varvects.S, varvects.h, rtems/asm.h, rtems/score/cpu.h, rtems/score/cpu_asm.h, rtems/score/m32c.h, rtems/score/types.h: New files.
Diffstat (limited to 'cpukit/score/cpu/m32c/Makefile.am')
-rw-r--r--cpukit/score/cpu/m32c/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/cpukit/score/cpu/m32c/Makefile.am b/cpukit/score/cpu/m32c/Makefile.am
new file mode 100644
index 0000000000..45be3a490b
--- /dev/null
+++ b/cpukit/score/cpu/m32c/Makefile.am
@@ -0,0 +1,22 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/automake/compile.am
+
+include_HEADERS = varvects.h
+
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = rtems/asm.h
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/m32c.h \
+ rtems/score/cpu_asm.h rtems/score/types.h
+
+noinst_LIBRARIES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c cpu_asm.c context_switch.S context_init.c \
+ varvects.S
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am