summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/lm32/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-04-14 13:44:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-04-14 13:44:29 +0000
commit7c4c284c4af4551627097f914ce048245213c481 (patch)
treeb4ca21e9cb1f8a2896755f8ad1443001f2dbf2ee /cpukit/score/cpu/lm32/Makefile.am
parentFix attribution. (diff)
downloadrtems-7c4c284c4af4551627097f914ce048245213c481.tar.bz2
2009-04-14 Michael Walle <michael@walle.cc>
* cpu.h: corrected the registers in Context_Control and in CPU_Interrupt_frame to correspond to the saved frame in cpu_asm.S Also switched on CPU_ISR_PASSES_FRAME_POINTER. * cpu_asm.S: Moved the restore part of _CPU_Context_switch for easier reading. Fixed _CPU_Context_restore, it now moves the argument and branches to a label in _CPU_Context_switch. Removed unnecessary saves of registers in context switch and irq handling. Rewrote irq code to call the C helper. Added some documentation * irq.c: New file derived from c4x and nios2.
Diffstat (limited to 'cpukit/score/cpu/lm32/Makefile.am')
-rw-r--r--cpukit/score/cpu/lm32/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/cpu/lm32/Makefile.am b/cpukit/score/cpu/lm32/Makefile.am
index 9d9b833f75..86af92f057 100644
--- a/cpukit/score/cpu/lm32/Makefile.am
+++ b/cpukit/score/cpu/lm32/Makefile.am
@@ -12,7 +12,7 @@ include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/lm32.h \
rtems/score/cpu_asm.h rtems/score/types.h
noinst_LIBRARIES = libscorecpu.a
-libscorecpu_a_SOURCES = cpu.c cpu_asm.S
+libscorecpu_a_SOURCES = cpu.c cpu_asm.S irq.c
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
include $(srcdir)/preinstall.am