summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/c4x/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-10 15:41:37 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-10 15:41:37 +0000
commit7a28ac8880b580689a225ed3776b70a15f96bcec (patch)
tree3697b9062e3c68ab9261f1629c614b6bfb73e483 /cpukit/score/cpu/c4x/Makefile.am
parent2008-09-10 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-7a28ac8880b580689a225ed3776b70a15f96bcec.tar.bz2
2008-09-10 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, aclocal/canonical-target-name.m4: Readd NIOS2 and TI C4x. Accidentally not done on 4.9 branch. :( * score/cpu/c4x/.cvsignore, score/cpu/c4x/ChangeLog, score/cpu/c4x/Makefile.am, score/cpu/c4x/cpu.c, score/cpu/c4x/cpu_asm.S, score/cpu/c4x/irq.c, score/cpu/c4x/preinstall.am, score/cpu/c4x/rtems/asm.h, score/cpu/c4x/rtems/score/c4x.h, score/cpu/c4x/rtems/score/cpu.h, score/cpu/c4x/rtems/score/cpu_asm.h, score/cpu/c4x/rtems/score/types.h, score/cpu/c4x/rtems/tic4x/c4xio.h, score/cpu/nios2/.cvsignore, score/cpu/nios2/ChangeLog, score/cpu/nios2/Makefile.am, score/cpu/nios2/cpu.c, score/cpu/nios2/cpu_asm.S, score/cpu/nios2/irq.c, score/cpu/nios2/preinstall.am, score/cpu/nios2/rtems/asm.h, score/cpu/nios2/rtems/score/cpu.h, score/cpu/nios2/rtems/score/cpu_asm.h, score/cpu/nios2/rtems/score/nios2.h, score/cpu/nios2/rtems/score/types.h: New files.
Diffstat (limited to 'cpukit/score/cpu/c4x/Makefile.am')
-rw-r--r--cpukit/score/cpu/c4x/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/cpukit/score/cpu/c4x/Makefile.am b/cpukit/score/cpu/c4x/Makefile.am
new file mode 100644
index 0000000000..e8ccf6da39
--- /dev/null
+++ b/cpukit/score/cpu/c4x/Makefile.am
@@ -0,0 +1,22 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/automake/compile.am
+
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = rtems/asm.h
+
+include_rtems_tic4xdir = $(includedir)/rtems/tic4x
+include_rtems_tic4x_HEADERS = rtems/tic4x/c4xio.h
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/c4x.h \
+ rtems/score/types.h rtems/score/cpu_asm.h
+
+noinst_LIBRARIES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c irq.c cpu_asm.S
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am