summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/bfin/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2006-10-23 17:17:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2006-10-23 17:17:50 +0000
commitd9a6ab3fed9e77a6343ee56571e4d9d767c8e979 (patch)
tree5cbb0283798520905ed50d799d1f19de959e7a55 /cpukit/score/cpu/bfin/Makefile.am
parent2006-10-22 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-d9a6ab3fed9e77a6343ee56571e4d9d767c8e979.tar.bz2
2006-10-23 Joel Sherrill <joel@OARcorp.com>
* .cvsignore, ChangeLog, Makefile.am, cpu.c, cpu_asm.S, irq.c, preinstall.am, rtems/asm.h, rtems/score/bfin.h, rtems/score/cpu.h, rtems/score/cpu_asm.h, rtems/score/types.h: New files.
Diffstat (limited to 'cpukit/score/cpu/bfin/Makefile.am')
-rw-r--r--cpukit/score/cpu/bfin/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/cpukit/score/cpu/bfin/Makefile.am b/cpukit/score/cpu/bfin/Makefile.am
new file mode 100644
index 0000000000..4c7e495f45
--- /dev/null
+++ b/cpukit/score/cpu/bfin/Makefile.am
@@ -0,0 +1,19 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/automake/compile.am
+
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = rtems/asm.h
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/bfin.h \
+ rtems/score/cpu_asm.h rtems/score/types.h
+
+noinst_LIBRARIES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c irq.c cpu_asm.S
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am