summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/avr/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-06 15:36:23 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-06 15:36:23 +0000
commit7c46cf58b3d774bf417d84bb55abb0c3360a7f1e (patch)
tree6c7964917751b010e2b3e586e78f98387596d8b9 /cpukit/score/cpu/avr/Makefile.am
parent2009-07-03 Josh Switnicki <josh.switnicki@utoronto.ca> (diff)
downloadrtems-7c46cf58b3d774bf417d84bb55abb0c3360a7f1e.tar.bz2
2009-07-03 Josh Switnicki <josh.switnicki@utoronto.ca>
* cpu.c: Implemented _CPU_Context_Initialize as a C function instead of a macro. It works with limited functionality. Implemented _CPU_Thread_Idle_body to use sleep instruction. * Makefile.am: Changed cpu_asm.c -> cpu_asm.S * cpu_asm.S: renamed from cpu_asm.c and implemented functions is asm * rtems/asm.h: Appended "macros.inc" to the end of "asm.h" * rtems/score/cpu.h: + Included "avr/io.h". + Added use 16 bit object definition. + Modified Context_Control struct to relect the registers that need to be saved. + Implemented _CPU_ISR_Disable, _CPU_ISR_Enable, and _CPU_ISR_Flash. Added function definitions for _CPU_Context_Initialize and _CPU_Push.
Diffstat (limited to 'cpukit/score/cpu/avr/Makefile.am')
-rw-r--r--cpukit/score/cpu/avr/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/cpu/avr/Makefile.am b/cpukit/score/cpu/avr/Makefile.am
index 69bd4636b9..06631baa36 100644
--- a/cpukit/score/cpu/avr/Makefile.am
+++ b/cpukit/score/cpu/avr/Makefile.am
@@ -12,7 +12,7 @@ include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/avr.h \
rtems/score/cpu_asm.h rtems/score/types.h
noinst_LIBRARIES = libscorecpu.a
-libscorecpu_a_SOURCES = cpu.c cpu_asm.c
+libscorecpu_a_SOURCES = cpu.c cpu_asm.S
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
include $(srcdir)/preinstall.am