summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/arm/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-11-06 22:51:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-11-06 22:51:08 +0000
commit661e5de43bea5199f8e7a9f5acb85eae1daaf9ea (patch)
tree514f1503907df66655d574d3547fe5c5b8951f84 /cpukit/score/cpu/arm/Makefile.am
parent2007-11-03 Ray Xu <rayx.cn@gmail.com> (diff)
downloadrtems-661e5de43bea5199f8e7a9f5acb85eae1daaf9ea.tar.bz2
2007-11-03 Ray Xu <rayx.cn@gmail.com>
* cpu.c, cpu_asm.S, score/cpu.h : add support for ARM<->THUMB veneer thumb new dir to controll CPSR/SPRS in thumb mode 2007-05-09 Ray Xu <rayx.cn@gmail.com> * cpu.c: move do_data_abort() to libbsp/arm/shared/abort/ implement a compact do_data_abort() in simple_abort.c
Diffstat (limited to 'cpukit/score/cpu/arm/Makefile.am')
-rw-r--r--cpukit/score/cpu/arm/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cpukit/score/cpu/arm/Makefile.am b/cpukit/score/cpu/arm/Makefile.am
index 2290aa4123..f02efb599a 100644
--- a/cpukit/score/cpu/arm/Makefile.am
+++ b/cpukit/score/cpu/arm/Makefile.am
@@ -1,9 +1,7 @@
##
## $Id$
##
-
include $(top_srcdir)/automake/compile.am
-
include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = rtems/asm.h
@@ -14,6 +12,8 @@ include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/cpu_asm.h \
noinst_LIBRARIES = libscorecpu.a
libscorecpu_a_SOURCES = cpu.c cpu_asm.S
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+SUBDIRS = thumb
+libscorecpu_a_LIBADD = ./thumb/libthumbisr_a-thumb_isr.o
include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am