summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/arm/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-07-17 17:14:31 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-07-17 17:14:31 +0000
commit4f0b287a4aa0d948d61f5c2ef1915c4db24f30e9 (patch)
treed66a2f77c384be5cff2c7c5f89619a06286ecd77 /cpukit/score/cpu/arm/Makefile.am
parent2002-07-17 Jay Monkman <jtm@smoothsmoothie.com> (diff)
downloadrtems-4f0b287a4aa0d948d61f5c2ef1915c4db24f30e9.tar.bz2
2002-07-17 Jay Monkman <jtm@smoothsmoothie.com>
* rtems/score/cpu_asm.h: Enhanced to include register offsets. * Makefile.am: Install rtems/score/cpu_asm.h. * cpu.c: Significantly enhanced including the implementation of _CPU_ISR_Get_level. * cpu_asm.S: Improved behavior of context switch and interrupt dispatching. * rtems/score/arm.h: Improved the CPU model name determination. * rtems/score/cpu.h: Improved interrupt disable/enable functions.
Diffstat (limited to 'cpukit/score/cpu/arm/Makefile.am')
-rw-r--r--cpukit/score/cpu/arm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/score/cpu/arm/Makefile.am b/cpukit/score/cpu/arm/Makefile.am
index fea8733ff3..03e6e36ebf 100644
--- a/cpukit/score/cpu/arm/Makefile.am
+++ b/cpukit/score/cpu/arm/Makefile.am
@@ -26,6 +26,7 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
include_rtems_scoredir = $(includedir)/rtems/score
include_rtems_score_HEADERS = \
rtems/score/cpu.h \
+ rtems/score/cpu_asm.h \
rtems/score/arm.h \
rtems/score/types.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \