summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/a29k/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-22 13:59:42 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-22 13:59:42 +0000
commitd1c83050711c2579c92ee2e4888f53a6658565ab (patch)
treec1a73bc02b24b18e8841b8e089657bc1a7c2e62b /cpukit/score/cpu/a29k/Makefile.am
parent2000-09-20 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-d1c83050711c2579c92ee2e4888f53a6658565ab.tar.bz2
2000-09-22 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, cpu_asm.S, psmacro.ah, rtems/score/cpu.h: First attempt to compile with GNU tools. Minor modifications to compile enough to get to assembler errors.
Diffstat (limited to 'cpukit/score/cpu/a29k/Makefile.am')
-rw-r--r--cpukit/score/cpu/a29k/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/cpukit/score/cpu/a29k/Makefile.am b/cpukit/score/cpu/a29k/Makefile.am
index 2da3c85306..6ad1a9aa81 100644
--- a/cpukit/score/cpu/a29k/Makefile.am
+++ b/cpukit/score/cpu/a29k/Makefile.am
@@ -5,26 +5,29 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../../../../automake/compile.am
-include $(top_srcdir)/../../../../../../automake/lib.am
-
SUBDIRS = rtems
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-H_FILES = amd.ah asm.h cpu_asm.h pswmacro.ah register.ah
+H_FILES = amd.ah asm.h pswmacro.ah register.ah
S_FILES = cpu_asm.S sig.S
S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/%.ah: %.ah
+ $(INSTALL_DATA) $< $@
+
$(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
$(INSTALL_DATA) $< $@