summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2015-04-14 10:01:05 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2015-04-14 11:17:10 -0500
commitfc0756e8d9caf1155e2df1ad4a1282619c6668f1 (patch)
treebf4aa3a51cac86cfb220a6d34ba7538d60fb780e /cpukit/score/Makefile.am
parentor1ksim: Fix bug at UART driver. (diff)
downloadrtems-fc0756e8d9caf1155e2df1ad4a1282619c6668f1.tar.bz2
Add test assertion for allocator mutex being unlocked
The Allocator Mutex should not be locked outside a tested service call. In an SMP test or heavily multithreaded test, this is possible since another thread could have the lock for an extended period of time but this is not the norm for the tests. updates 2319.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index dc51e9a691..f0cd67641c 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -149,7 +149,7 @@ endif
## CORE_APIMUTEX_C_FILES
libscore_a_SOURCES += src/apimutex.c \
- src/apimutexlock.c src/apimutexunlock.c
+ src/apimutexlock.c src/apimutexislocked.c src/apimutexunlock.c
## CORE_BARRIER_C_FILES
libscore_a_SOURCES += src/corebarrier.c src/corebarrierrelease.c \