summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-14 13:50:48 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-15 12:18:44 +0200
commitf39f667a69cf5c4bc0dd4555537615022767f0f9 (patch)
treef8a48b3c7bf443001b036ddcab6ed104210e6134 /cpukit/score/Makefile.am
parentscore: Add and use _Scheduler_Get_context() (diff)
downloadrtems-f39f667a69cf5c4bc0dd4555537615022767f0f9.tar.bz2
score: Simplify _Thread_Change_priority()
The function to change a thread priority was too complex. Simplify it with a new scheduler operation. This increases the average case performance due to the simplified logic. The interrupt disabled critical section is a bit prolonged since now the extract, update and enqueue steps are executed atomically. This should however not impact the worst-case interrupt latency since at least for the Deterministic Priority Scheduler this sequence can be carried out with a wee bit of instructions and no loops. Add _Scheduler_Change_priority() to replace the sequence of - _Thread_Set_transient(), - _Scheduler_Extract(), - _Scheduler_Enqueue(), and - _Scheduler_Enqueue_first(). Delete STATES_TRANSIENT, _States_Is_transient() and _Thread_Set_transient() since this state is now superfluous. With this change it is possible to get rid of the SCHEDULER_SMP_NODE_IN_THE_AIR state. This considerably simplifies the implementation of the new SMP locking protocols.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 8fb11d7bdf..ed68ee0072 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -208,9 +208,7 @@ libscore_a_SOURCES += src/schedulerdefaultupdate.c
## SCHEDULERPRIORITY_C_FILES
libscore_a_SOURCES += src/schedulerpriority.c \
src/schedulerpriorityblock.c \
- src/schedulerpriorityenqueue.c \
- src/schedulerpriorityenqueuefirst.c \
- src/schedulerpriorityextract.c \
+ src/schedulerprioritychangepriority.c \
src/schedulerpriorityprioritycompare.c \
src/schedulerpriorityschedule.c \
src/schedulerpriorityunblock.c \
@@ -220,11 +218,7 @@ libscore_a_SOURCES += src/schedulerpriority.c \
## SCHEDULERSIMPLE_C_FILES
libscore_a_SOURCES += src/schedulersimple.c \
src/schedulersimpleblock.c \
- src/schedulersimpleenqueue.c \
- src/schedulersimpleenqueuefirst.c \
- src/schedulersimpleextract.c \
- src/schedulersimplereadyqueueenqueue.c \
- src/schedulersimplereadyqueueenqueuefirst.c \
+ src/schedulersimplechangepriority.c \
src/schedulersimpleschedule.c \
src/schedulersimpleunblock.c \
src/schedulersimpleyield.c
@@ -233,9 +227,7 @@ libscore_a_SOURCES += src/schedulersimple.c \
libscore_a_SOURCES += src/scheduleredf.c \
src/scheduleredfallocate.c \
src/scheduleredfblock.c \
- src/scheduleredfenqueue.c \
- src/scheduleredfenqueuefirst.c \
- src/scheduleredfextract.c \
+ src/scheduleredfchangepriority.c \
src/scheduleredfprioritycompare.c \
src/scheduleredfreleasejob.c \
src/scheduleredfschedule.c \
@@ -282,7 +274,7 @@ libscore_a_SOURCES += src/thread.c src/threadchangepriority.c \
src/threadget.c src/threadhandler.c src/threadinitialize.c \
src/threadloadenv.c src/threadready.c \
src/threadrestart.c src/threadsetpriority.c \
- src/threadsetstate.c src/threadsettransient.c \
+ src/threadsetstate.c \
src/threadstackallocate.c src/threadstackfree.c src/threadstart.c \
src/threadstartmultitasking.c src/iterateoverthreads.c \
src/threadblockingoperationcancel.c