summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-04-20 09:50:01 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-04-21 08:25:32 +0200
commitd3802bb5d708d01d03774b6758ed1e87484b8fac (patch)
tree40ff15dcafece4b9e5a72eb9706831d44ab2c5dc /cpukit/score/Makefile.am
parentscore: Add _Thread_Get_interrupt_disable() (diff)
downloadrtems-d3802bb5d708d01d03774b6758ed1e87484b8fac.tar.bz2
score: Delete object control block ISR lock
The Objects_Control::Lock was a software layer violation. It worked only for the threads since they are somewhat special. Update #2273.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index b12124c469..0a6beb4522 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -203,7 +203,6 @@ libscore_a_SOURCES += src/objectallocate.c src/objectclose.c \
src/objectgetinfo.c src/objectgetinfoid.c src/objectapimaximumclass.c \
src/objectnamespaceremove.c \
src/objectactivecount.c
-libscore_a_SOURCES += src/objectacquire.c
## SCHEDULER_C_FILES
libscore_a_SOURCES += src/log2table.c