summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-11-26 16:38:06 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-11-26 16:38:06 +0000
commitc8f7b4e6ca8c9d1c17f2bf6a6278bc4d406b6835 (patch)
tree905e6115a43c8a635388f24a1c4b4adf055333ea /cpukit/score/Makefile.am
parent2008-11-26 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-c8f7b4e6ca8c9d1c17f2bf6a6278bc4d406b6835.tar.bz2
2008-11-26 Joel Sherrill <joel.sherrill@oarcorp.com>
* score/Makefile.am, score/include/rtems/score/watchdog.h: Add _Watchdog_Report and _Watchdog_Report_chain as debug assist routines. They are NOT to be used in directives. * score/src/watchdogreport.c, score/src/watchdogreportchain.c: New files.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index a3a4d603a5..0ea422fce6 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -173,7 +173,8 @@ libscore_a_SOURCES += src/coretod.c src/coretodset.c src/coretodget.c \
## WATCHDOG_C_FILES
libscore_a_SOURCES += src/watchdog.c src/watchdogadjust.c \
- src/watchdoginsert.c src/watchdogremove.c src/watchdogtickle.c
+ src/watchdoginsert.c src/watchdogremove.c src/watchdogtickle.c \
+ src/watchdogreport.c src/watchdogreportchain.c
## USEREXT_C_FILES
libscore_a_SOURCES += src/userextaddapiset.c src/userextaddset.c \