summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-15 09:41:20 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-15 12:18:49 +0200
commitb4bdbcfe2738c8ca007801f5a281bdda3a947aca (patch)
tree2d790830ae62b513d0d1cdeb92524aeb40ab9664 /cpukit/score/Makefile.am
parentscore: Add and use _Scheduler_SMP_Start_idle() (diff)
downloadrtems-b4bdbcfe2738c8ca007801f5a281bdda3a947aca.tar.bz2
score: Make _Thread_queue_Requeue() static
This function is only used by _Thread_Change_priority(). Make it static to avoid the function call overhead in the performance critical function _Thread_Change_priority().
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 200d11d9c8..7c426025ea 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -293,7 +293,7 @@ libscore_a_SOURCES += src/threadq.c src/threadqdequeue.c \
src/threadqenqueuepriority.c src/threadqextract.c \
src/threadqextractfifo.c src/threadqextractpriority.c \
src/threadqextractwithproxy.c src/threadqfirst.c src/threadqfirstfifo.c \
- src/threadqfirstpriority.c src/threadqflush.c src/threadqrequeue.c \
+ src/threadqfirstpriority.c src/threadqflush.c \
src/threadqprocesstimeout.c src/threadqtimeout.c
## TIMESPEC_C_FILES