summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-29 17:52:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-29 17:52:10 +0000
commita55e305ed3406b935a24ceb9becdff58a1a87948 (patch)
treeb4745978fb84fecc82b1b3d0d0cb7aa0eec8d4a7 /cpukit/score/Makefile.am
parent2010-07-29 Gedare Bloom <giddyup44@yahoo.com> (diff)
downloadrtems-a55e305ed3406b935a24ceb9becdff58a1a87948.tar.bz2
2010-07-29 Gedare Bloom <giddyup44@yahoo.com>
PR 1635/cpukit * sapi/src/exinit.c, score/Makefile.am, score/preinstall.am, score/include/rtems/score/bitfield.h, score/include/rtems/score/priority.h, score/include/rtems/score/thread.h, score/inline/rtems/score/priority.inl, score/inline/rtems/score/thread.inl, score/src/threadchangepriority.c, score/src/threadclearstate.c, score/src/threadready.c, score/src/threadresume.c, score/src/threadsetpriority.c, score/src/threadsetstate.c, score/src/threadsettransient.c, score/src/threadsuspend.c: Refactoring of priority handling, to isolate the bitmap implementation of priorities in the supercore so that priority management is a little more modular. This change is in anticipation of scheduler implementations that can select how they manage tracking priority levels / finding the highest priority ready task. Note that most of the changes here are simple renaming, to clarify the use of the bitmap-based priority management. * score/include/rtems/score/prioritybitmap.h, score/inline/rtems/score/prioritybitmap.inl: New files.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am29
1 files changed, 15 insertions, 14 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 01978fce3a..43d53e0526 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -25,15 +25,15 @@ include_rtems_score_HEADERS = include/rtems/score/address.h \
include/rtems/score/heap.h include/rtems/score/protectedheap.h \
include/rtems/score/interr.h include/rtems/score/isr.h \
include/rtems/score/object.h include/rtems/score/percpu.h \
- include/rtems/score/priority.h include/rtems/score/stack.h \
- include/rtems/score/states.h include/rtems/score/sysstate.h \
- include/rtems/score/thread.h include/rtems/score/threadq.h \
- include/rtems/score/threadsync.h include/rtems/score/timespec.h \
- include/rtems/score/timestamp.h include/rtems/score/timestamp64.h \
- include/rtems/score/tod.h include/rtems/score/tqdata.h \
- include/rtems/score/userext.h include/rtems/score/watchdog.h \
- include/rtems/score/wkspace.h include/rtems/score/cpuopts.h \
- include/rtems/score/basedefs.h
+ include/rtems/score/priority.h include/rtems/score/prioritybitmap.h \
+ include/rtems/score/stack.h include/rtems/score/states.h \
+ include/rtems/score/sysstate.h include/rtems/score/thread.h \
+ include/rtems/score/threadq.h include/rtems/score/threadsync.h \
+ include/rtems/score/timespec.h include/rtems/score/timestamp.h \
+ include/rtems/score/timestamp64.h include/rtems/score/tod.h \
+ include/rtems/score/tqdata.h include/rtems/score/userext.h \
+ include/rtems/score/watchdog.h include/rtems/score/wkspace.h \
+ include/rtems/score/cpuopts.h include/rtems/score/basedefs.h
if HAS_PTHREADS
include_rtems_score_HEADERS += include/rtems/score/corespinlock.h \
@@ -53,11 +53,12 @@ include_rtems_score_HEADERS += inline/rtems/score/address.inl \
inline/rtems/score/coremsg.inl inline/rtems/score/coremutex.inl \
inline/rtems/score/coresem.inl inline/rtems/score/heap.inl \
inline/rtems/score/isr.inl inline/rtems/score/object.inl \
- inline/rtems/score/priority.inl inline/rtems/score/stack.inl \
- inline/rtems/score/states.inl inline/rtems/score/sysstate.inl \
- inline/rtems/score/thread.inl inline/rtems/score/threadq.inl \
- inline/rtems/score/tod.inl inline/rtems/score/tqdata.inl \
- inline/rtems/score/watchdog.inl inline/rtems/score/wkspace.inl
+ inline/rtems/score/priority.inl inline/rtems/score/prioritybitmap.inl \
+ inline/rtems/score/stack.inl inline/rtems/score/states.inl \
+ inline/rtems/score/sysstate.inl inline/rtems/score/thread.inl \
+ inline/rtems/score/threadq.inl inline/rtems/score/tod.inl \
+ inline/rtems/score/tqdata.inl inline/rtems/score/watchdog.inl \
+ inline/rtems/score/wkspace.inl
if HAS_PTHREADS
include_rtems_score_HEADERS += inline/rtems/score/corespinlock.inl \