summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2004-11-29 22:45:43 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2004-11-29 22:45:43 +0000
commit9b3f187a02049d81a63bb85497c5a4ebb9d37a97 (patch)
tree7796f90657fdd839f998a88f2cc4d0688ffb29c9 /cpukit/score/Makefile.am
parentAdd another module ID code. (diff)
downloadrtems-9b3f187a02049d81a63bb85497c5a4ebb9d37a97.tar.bz2
2004-11-29 Joel Sherrill <joel@OARcorp.com>
* libcsupport/src/mallocfreespace.c, rtems/Makefile.am, rtems/include/rtems/rtems/region.h, score/Makefile.am, score/include/rtems/score/heap.h, score/src/heapgetinfo.c: Add capability to return information about just the free blocks in a region or heap. Also changed the semantics of free space available to be the largest block of memory that can be allocated. * rtems/src/regiongetfreeinfo.c, score/src/heapgetfreeinfo.c: New files. : score/include/rtems/score/object.h, score/src/objectinitializeinformation.c: Remove warning.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index ab4af5f5ca..3188f22f9d 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -94,7 +94,8 @@ CORE_SEMAPHORE_C_FILES = src/coresem.c src/coresemflush.c src/coresemseize.c \
src/coresemsurrender.c
HEAP_C_FILES = src/heap.c src/heapallocate.c src/heapextend.c src/heapfree.c \
- src/heapsizeofuserarea.c src/heapwalk.c src/heapgetinfo.c
+ src/heapsizeofuserarea.c src/heapwalk.c src/heapgetinfo.c \
+ src/heapgetfreeinfo.c
OBJECT_C_FILES = src/object.c src/objectallocate.c \
src/objectallocatebyindex.c src/objectclearname.c \